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Foreword 

Thank you for choosing a Kistler quality product 
characterized by technical innovation, precision and long 
life. 
 
Information in this document is subject to change without 
notice. Kistler reserves the right to change or improve its 
products and make changes in the content without 
obligation to notify any person or organization of such 
changes or improvements. 
 
©2012 Kistler Group. All rights reserved. Except as 
expressly provided herein, no part of this manual may be 
reproduced for any purpose without the express prior 
written consent of Kistler Group. 
 
 
 
Kistler Group 
Eulachstrasse 22 
8408 Winterthur 
Switzerland 
Tel. +41 52 224 11 11  
Fax +41 52 224 14 14 
info@kistler.com 
www.kistler.com 
 
 
 

 

http://www.kistler.com/
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1. Introduction 

Please take the time to thoroughly read this instruction 
manual. It will help you with the installation, maintenance, 
and use of this product. 
 
To the extent permitted by law Kistler does not accept any 
liability if this instruction manual is not followed or 
products other than those listed under Accessories are 
used.  
 
Kistler offers a wide range of products for use in measuring 
technology: 
 Piezoelectric sensors for measuring force, torque, strain, 

pressure, acceleration, shock, vibration and acoustic-
emission 

 Strain gage sensor systems for measuring force and 
torque 

 Piezoresistive pressure sensors and transmitters 
 Signal conditioners, indicators and calibrators 
 Electronic control and monitoring systems as well as 

software for specific measurement applications 
 Data transmission modules (telemetry) 
 
Kistler also develops and produces measuring solutions for 
the application fields of engines, vehicles, manufacturing, 
plastics and biomechanics sectors. 
 
Our product and application brochures will provide you 
with an overview of our product range. Detailed data 
sheets are available for almost all products. 
 
If you need additional help beyond what can be found 
either on-line or in this manual, please contact Kistler's 
extensive support organization. 
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1.1 Disposal Instructions for Electrical and Electronic Equipment 

 
Do not discard old electronic instruments in municipal 
trash. For disposal at end of life, please return this 
product to an authorized local electronic waste disposal 
service or contact the nearest Kistler Instrument sales 
office for return instructions. 

 

1.2 Software Upgrades and Updates 

Kistler may from time to time supply upgrades or updates 
for embedded software. Such upgrades or updates must 
always be installed.  
 
Kistler declines any liability whatsoever for any direct or 
consequential damage caused by products running on 
embedded software which has not been upgraded or 
updated with the latest software supplied. 
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- measurement of time intervals (between each curves)
- measurement of velocity (by use of known base)
- independent selection of rising or falling edges
- independent setting of threshold levels
- time filter for elimination of shockwaves

(between two edges)

Time Interval & Velocity

THRESHOLD
LEVEL

t

2. Data Evaluation 
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- measurement of time intervals (between each curves)
- measurement of velocity (by use of known base)
- independent selection of first zero-crossing after
   crossing of the threshold level from left to right
   or from right to left direction
- time filter for elimination of shockwaves

(between two zero-crossings)

Time Interval & Velocity

THRESHOLD
LEVEL

t
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- measurement of time intervals (between each curves)
- measurement of velocity (by use of known base)
- program determines time interval between rising edges
  of start integral curve and stop integral curve
- especially designed for measurement of velocity by use
  of centre of gravity (pellets etc.)

( )by use of integral

Time Interval & Velocity

THRESHOLD
LEVEL

t
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- measurement of curve maximum (Pmax etc.)
- measurement of time position of maximum
  (time interval between accelerometer and Pmax)
- filter for noise supression

(and time position of maximum)

Maximum Value of Curve

Pmax

t
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- measurement of integral (area) of curve between
  two cursors

(between two cursors)

Integral of Curve

AREA

t

  



 Data Evaluation and Reference Manual Transient Recorder Type 2519A… 

Page 10  2519A_002-607e-10.12 

- measurement of integral (area) of curve between
  two events (see picture) : start of integration is derived
  from accelerometer signal (yellow curve), stop
  is derived from muzzle sensor (green curve)
- independent selection of rising or falling edges
- time filter for noise supression

(between two events)

Integral of Curve

AREA

t
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- measurement of derivation (slope, dy/dt) of curve
  between two cursors

(between two cursors)

Derivation of Curve

dy

dt
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- measurement of derivation (slope, dy/dt) of curve
  between two levels (in % of curve maximum)
- each level is adjustable in range 0-100%
- designed for easy measurement of curve slew rate

(between two levels)

Derivation of Curve

10% Pmax

90% Pmax

dy

dt Pmax
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- measurement of Rate Of Fire between all
  consecutive shots
- measurement of velocity (by use of known base)
  for all shots
- independent selection of rising or falling edges
- independent setting of threshold levels
- time filter for elimination of shockwaves

(between two consecutive shots)

Rate Of Fire

THRESHOLD
LEVEL

ti
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- measurement of hit position and target velocity
  by use of  electronic target system DTS01/02
- ratio of intervals t1 and t2 determines X (or Y)
  coordinate of hit
- independent selection of rising or falling edges,
  threshold levels and shockwave filters for X and
  for Y coordinate

(2x DTS01/02)

Target System

THRESHOLD
LEVEL

t2t1
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- measurement of function value of curve Y=f(X)
  for entered fixed value of X

(Y = f(X) for fixed value of X)

Function Value of Curve

Y= (X)f

X
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- measurement of function value of curve Y=f(X)
  at event X (rising or falling edge of impulse)

(Y = f(X) )at event

Function Value of Curve

Y= (X)f
X
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- 
- 

testing of shape of curve (Pass / Fail)
unlimited number of masks with save/load option

(PASS / FAIL testing)

Limit Mask

MIN

MAX
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- measurement of average value of curve between
  two cursors

(between two cursors)

Average Value of Curve

AVG
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(input of numeric 
)

value which
 will be processed with data

User Value

(only BA04SE - four start-stop
 counters for measuring of time
 intervals up to 429s with 100ns
 resolution)

Counter
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Conversion Table (PSI approx.) 
  
  1  bar = 0.1  MPa  = 14.5 PSI 
  10  bar = 1  MPa  = 145 PSI 
  0.0690 bar = 0.00690 MPa  = 1 PSI 
   
  1  bar/V = 0.1  MPa/V = 14.5 PSI/V 
  10  bar/V = 1  MPa/V = 145 PSI/V 
  0.0690 bar/V = 0.00690 MPa/V = 1 PSI/V 
   
  1 pC/bar = 10 pC/MPa  = 0.0690 pC/PSI 
  0.1 pC/bar = 1 pC/MPa  = 0.00690 pC/PSI 
  14.5 pC/bar = 145 pC/MPa  = 1  pC/PSI 
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3. Reference Instructions 

3.1 TR 2519: Block Diagram 
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 BA06 TIME MEAS. ACCURACY

 Total Error, max. @ Tcal, [s] : (0.01% of Time) + (2/SR)

 SR = Sample Rate (20 kHz = 20 000, 5 MHz = 5 000 000, etc.)
 Time = measured value of time (START - STOP)
 Temperature coefficient < 0.001%/°C

 BA06 VELOCITY MEAS. ACCURACY
 (with WLS03 or WTS03)

 Total Error, max. @ Tcal, [%] : 0.05 + 200 / (Time × SR)

 SR = Sample Rate (20 kHz = 20 000, 5 MHz = 5 000 000, etc.)
 Time = measured value of time (START - STOP)
 Temperature coefficient < 0.005%/°C

 CHARGE AMPLIFIERS

 Type : IM06-0-CHGA
(For High-Speed and Quasistatic Measurements)

 Input Ranges (FSR) : Range dQ/dt @ AZON dQ/dt @ AZOFF
[pC] max. [pC/s] max. [pC/s]

2 600 80 2
5 200 80 2

10 600 80 2
20 200 80 2

 Bandwidth (-3dB), min. [kHz] : Filter Bandwidth Rise/Fall Edge
 (Bessel 2nd order Low-Pass Filter) [kHz] [kHz] max. [µs]

10 10 50
20 20 25
40 40 12

OFF >100 4
 Nonlinearity, max. [%] of FS 0.1
 Total Error, max. [%] of FS @ Tcal 0.5  (AZOn)
 TK, max. [%/°C] 0.005
 Noise (Peak Value, Unfiltered) < 0.1% FSR
 Capacity of Cable & Sensor : unlimited  (guaranteed stability only)
 Automatic Drift Compensation : yes
 High-Speed Discharge : yes
 High-Speed Overload Recovery : yes
 High-Speed Overload
 Recovery Time, max. [s] : 1
 Max. Input Voltage
 (DC or AC <1kHz) [V] : 50

 VOLTAGE INPUTS

 Type : IM07-0-D2SA IM07-1-D2HG
(Differential, (Single Ended, Two Channels,
Two Channels) High-Gain)

 Input Ranges :
Range [V]

G=1
Range [V]

G=1
Range [V]

G=10
Range [V]

G=100
1 1 0.1 0.01
2 2 0.2 0.02
5 5 0.5 0.05

10 10 1.0 0.10
 Input Impedance [kOhm] : 10 10 10 10
 Slew Rate, min. [V/us] : 10 10 10 10
 Bandwidth, min [kHz] : 400 400 400 100
 Nonlinearity, max. [%] of FS 0.1 0.1 0.1 0.2
 Total Error, max. [%] of FS @ Tcal 1.0 1.0 1.0 2.0
 Max. Input Voltage
 (DC or AC <1kHz) [V] : 50 50 50 50

 CHARGE CALIBRATOR

 Type : BA06PCAL

 Output Voltage [V]: ±2.4000
 Output Voltage Step [V]: 0.0001
 Output Voltage Error, max. [% of FS]: ±0.050
 Output Voltage Temperature Drift, max. [% of FS / °C]: ±0.002
 Output Voltage Time Drift, typ. [% of FS / 1000 hours]: ±0.005
 Output Voltage Noise, 0.1-10Hz, typ. [µVpp]: 5
 Output Impedance, typ. [Ohm]: 100

 BA06PCAL is precision voltage-step source, which is converted
 by means of precision reference capacitor to charge.

 Recommended calibration capacitor : 
 KISTLER 5371A10000 (10nF nom. ±0.1%)

 BA06S COMMON PARAMETERS

 Input Channels :  Max. 8 Independent Channels (ADC+RAM), Full Synchronised
 Analog to Digital Converter (ADC) :  14 bit (±13 bit), ±5V Input Range
 Memory (RAM)  512k x 16 bit SRAM

 Max. 400 000 Points Accessible
 Max. -100 000 Points (Pretrigger), +300 000 Points (Posttrigger)

 Sample Rate & Record Length :  Sample Rate :  Pretrigger [Points] :  Pretrigger [ms] :  Posttrigger [Points] :  Posttrigger [ms] :  BREAK Function :
   10.0 MHz (MSa/s)  - 100 000  - 10  + 300 000  + 30 No
     5.0 MHz (MSa/s)  - 100 000  - 20  + 300 000  + 60 No
     2.0 MHz (MSa/s)  - 100 000  - 50  + 300 000  + 150 No
     1.0 MHz (MSa/s)  - 100 000  - 100  + 300 000  + 300 No
     0.5 MHz (MSa/s)  - 100 000  - 200  + 300 000  + 600 No
     0.2 MHz (MSa/s)  - 100 000  - 500  + 300 000  + 1 500 No
     0.1 MHz (MSa/s)  - 100 000  - 1 000  + 300 000  + 3 000 No
    50.0 kHz (kSa/s)  - 100 000  - 2 000  + 300 000  + 6 000 Yes
    20.0 kHz (kSa/s)  - 100 000  - 5 000  + 300 000  + 15 000 Yes
    10.0 kHz (kSa/s)  - 100 000  - 10 000  + 300 000  + 30 000 Yes
      5.0 kHz (kSa/s)    - 50 000  - 10 000  + 300 000  + 60 000 Yes
      2.0 kHz (kSa/s)    - 20 000  - 10 000  + 300 000  + 150 000 Yes
      1.0 kHz (kSa/s)    - 10 000  - 10 000  + 300 000  + 300 000 Yes
      0.5 kHz (kSa/s)      - 5 000  - 10 000  + 300 000  + 600 000 Yes
      0.2 kHz (kSa/s)      - 2 000  - 10 000  + 300 000  + 1 500 000 Yes
      0.1 kHz (kSa/s)      - 1 000  - 10 000  + 300 000  + 3 000 000 Yes

 Time Base Parameters :  X-tal Controlled, Error < ±100 ppm, Ageing < ±5 ppm/year, Shock Resistance < ±20 ppm, Temperature Coefficient < ±1 ppm/°C
 Time Measurement Error :  ±((0.0001 * Time) + 2 / (Sample Rate))

 Time = Measured Value of Time in [s] (between START and STOP Cursor), Sample Rate in [Hz]
 Temperature Coefficient < ±10 ppm/°C

 Trigger :  Trigger Source :  Channel A (CH0) to Channel H (CH7)
 Trigger Level :  0 to ±87.5 % of Full Scale in 12.5 % Increments
 Trigger Edge :  Rising or Falling

 Power Supply :  Voltage :  nom. 12V DC (11 - 26V DC) - External 100 - 240V AC Power Adapter included
 Consumption :  nom. 25W (max. 40W)

 Operating Conditions :  Temperature Range :  -20°C to +40°C
 Relative Humidity :  Less than 90% (no condensation)
 Sealing :  IP51

3.2 TR 2519: Technical Specifications 
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Pay Attention to maximum input voltage of all input 
modules. Exceeding of maximum values could destroy 
this instrument! 

 
Maximum input voltage of channels (DC and AC up to 
1 kHz): 
Charge amplifier  IM06-x-CHGA (Channel A-D) 
   ± 50V/0.01A 
  (enter pin of BNC connector against its metal body) 
 
Voltage Input (Differential) IM07-0-D2SA (Channel E-H)
   ± 50V/0.01A 
  (center pin of BNC connector against its metal body) 
 
Voltage Input (Single Ended) IM07-1-D2HG (Channel E-H)
   ± 50V/0.01A 
(center pin of BNC connector against its metal body) 
 
Maximum voltage between channels (DC and AC up to 
1 kHz): 
Charge amplifier  IM06-x-CHGA (Channel A-D) 
   ± 0.5V/0.1A 
 between any two Charge Amplifiers (metal body of 

BNC connectors) 
 between any Charge Amplifier (metal body of BNC 

connector) and output connector (Ethernet, Signal Box) 
or GND 

 
Voltage Input (Differential) IM07-0-D2SA (Channel E-H)
   ± 50V/0.01A 
 
 between any two Voltage Inputs (metal body of BNC 

connectors) 
 between any Voltage Input (metal body of BNC 

connector) and output connector (Ethernet, Signal Box) 
or GND 

 
Voltage Input (Single Ended) IM07-1-D2HG (Channel E-H)
   ± 0.5V/0.1A 
 
 between any two Voltage Inputs (metal body of BNC 

connectors) 
 between any Voltage Input (metal body of BNC 

connector) and output connector (Ethernet, Signal Box) 
or GND 

 
In standard configuration all input modules are NOT 
galvanically isolated! 
 
Warm-up time of TR 2519 for guaranteed accuracy: 
approximately 5 minutes after switch-on 
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Dimensions (approx.) 
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3.3 TR 2519: Description of Front and Rear Panel 

3.3.1 Front Panel 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
BNC Connectors A,B,C,D 
 inputs of Charge Amplifiers for connection of piezo-

sensors 
 

BNC Connectors E,F,G,H 
 inputs of Voltage Amplifiers for connection of sensors 

with voltage output 
 both signals in the same group are added together 

 
BNC Connector CAL 
 output of precision charge calibrator 
 unprotected output - DO NOT APPLY ANY EXTERNAL 

VOLTAGE !!! 
 

STATUS LED indicators 
 POWER signalizes turning-on of equipment 
 READY indicates waiting for trigger event 
 DATA indicates recalculation and data transport to 

computer 
 

CALIBRATOR LED indicator 
 PULSE signalizes active calibrator output 
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3.3.2 Rear Panel 

 
 
 
 
 
 

 
 
 
 
 
 
 
 
 
 
 

POWER INPUT circular connector 
 11 … 26 VDC power input (pin 2 positive, pin 5 nega-

tive, protected) 
 

POWER ON/OFF switch 
 turning-on of equipment 

 
ETHERNET connector (Cannon 9 pin female) 
 data communication with computer 
 Ethernet 10/100Mb (pin 2 = RX neg., pin 4 = TX neg, 

pin 8 = RX pos., pin 9 = TX pos.) 
 

SIGNAL BOX connector (Cannon 9 pin male) 
  indication "Ready for Shot" 
 current loop, length max. 100m (cable resistance less 

than 100 Ohm) 
 galvanically isolated from TR 2519 
 approx. 12 VDC/440 Ohm loop (pin 1,2 = pos., pin 4,5 

= neg.) 
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3.4 Detailed Description of All Functions of Control Program 

3.4.1 Main TR 2519 Control Window 
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 Menu File 3.4.1.1

File > New...   Ctrl+N    
Creates a new directory on the disc and starts a new series. 
The name of this directory is corresponding with the name 
of new rounds series. 
Minimum length of the name is four characters !!! 
MAXIMUM NUMBER OF SHOTS IS LIMITED TO 250 for 
one round series. 
 

File > Open...   Ctrl+O    
Loading of measured data from the disc for their 
evaluation or for shooting another rounds into this loaded 
series. 
 
File > Open ref... 
Loading of the reference curve from disc for comparison 
with measured data. 
 

File > Save...   Ctrl+S    
Saving of the measured data. Data are stored automatically 
after measurement, but if evaluation was changed or some 
round was deleted you have to save data again. 
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File > Save ref... 
Saving of the reference curve on the disc for future 
comparison with measured data (it is accessible only in 
graph of statistic and in case of selection of only single 
group of data). 
 
File > Save method... 
Saving of the measuring method (setting of TR 2519 + 
data evaluation), which is extracted from the actual data. 
 

File > Save report   
Saving of the reports into folder BA_Results (according to 
actual settings of graphs and data evaluation). It has no 
influence to reports saved common with data. 
 
File > ASCII Export of series (all rounds)... 
Saving the measured data in ASCII format on the disk (for 
transport to mathematic or other programs). The user has 
the option to select a standard or user defined data 
separator. Data format is not described in this manual. In 
case of your interest please contact your dealer or 
developer. 
 
File > ASCII Export of series – selected area (actual 
round)... 
This special function serves for ASCII export of one round. 
Main feature is possibility of reduction of exported data 
points to easy reading by other software (MS Excel etc.). 
First it is necessary to activate the function Zoom (by 

means of button  etc.). Then show or hide relevant 

curves by means of buttons with symbol of eye  
and select required interval by means of vertical cursors. 
Next select from menu File this ASCII export (ASCII Export 
of selected area (actual round)) and then appears the 
window for reduction of points: 
 
Interval – all window - ASCII Export of all window (whole 
measured curve). 
Interval – between cursors - ASCII Export of data between 
vertical cursors (all measured points between cursors). 
Interval - between cursors, reduced - ASCII Export of data 
between vertical cursors reduced to selected number of 
points: 
Points: number of required points after reduction 
Select moving cursor: determines moving cursor and 
direction of its moving by correction of interval (which is 
necessary for successful reduction algorithm) 
Select algorithm: determines algorithm for reduction 
number of points (only skip the points or substitute points 
by its average value). 
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After OK appears standard dialog window for ASCII 
export, which allow to enter the name of data export.  
Default name is derived from filename and number of shot: 
NAME_XXX_YYY.txt, where XXX is shot number and YYY 
is number of export. 
For example: 2005-07-28 - 5.56x45 NATO EPVAT+ DTS 
003_005_001.txt 
Data separator is TAB, extension is .txt (text file). 
Program automatically increments number of export YYY 
(for data protection). 
Header of export is filled with information about hardware 
setting of TR 2519 channels (description of the terms is in 
chapter C 4.4.4 Calibration of  sensor and measuring 
chain). 
First column is time in [ms], next contains data of relevant 
channels. 
CAUTION – ASCII export always uses software internal 
units ([ms], [bar], [V], [user defined]). Actual setting of 
units in software have no influence to ASCII export. 
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Time Channel number : 0 Channel number : 1 Channel number : 2
Channel name : Charge amplifier Channel name : Charge amplifier Channel name : Charge amplifier

IM01-1-CHGA IM01-1-CHGA IM01-0-CHGA
User text : Pressure User text : Port User text : Accelerometer

Constant :  pC/bar 1.45E+00 Constant :  pC/bar 2.26E+00 Constant :  pC/bar -1.00E+01
Range :  4 280 bars pC 6.20E+03 Range :  2 740 bars pC 6.20E+03 Range : - 20 000 bars pC 2.00E+05
Filter : kHz 40 Filter : kHz 40 Filter : kHz 40

Auto-zero on Auto-zero on Auto-zero on

ms bar bar bar
-1.00E+00 1.34E+00 7.48E-01 -2.31E+01
-9.95E-01 1.03E+00 6.12E-01 -2.11E+01
-9.90E-01 4.13E-01 4.08E-01 -1.66E+01
-9.85E-01 1.34E+00 6.80E-01 -2.26E+01
-9.80E-01 8.25E-01 1.02E+00 -2.21E+01
-9.75E-01 1.65E+00 1.09E+00 -2.06E+01
-9.70E-01 2.06E-01 6.80E-01 -1.86E+01
-9.65E-01 1.03E+00 4.76E-01 -2.11E+01
-9.60E-01 8.25E-01 2.72E-01 -2.16E+01
-9.55E-01 1.03E+00 2.04E-01 -1.81E+01
-9.50E-01 2.06E-01 4.08E-01 -2.11E+01
-9.45E-01 1.44E+00 8.16E-01 -1.86E+01
-9.40E-01 5.16E-01 6.80E-01 -1.56E+01
-9.35E-01 6.19E-01 6.80E-01 -1.61E+01
-9.30E-01 6.19E-01 4.76E-01 -1.25E+01
-9.25E-01 3.09E-01 4.76E-01 -1.46E+01
-9.20E-01 1.13E+00 7.48E-01 -1.00E+01
-9.15E-01 8.25E-01 6.12E-01 -6.52E+00
-9.10E-01 4.13E-01 1.36E-01 3.01E+00
-9.05E-01 1.13E+00 9.52E-01 -2.51E+00
-9.00E-01 4.13E-01 6.80E-01 -2.51E+00
-8.95E-01 8.25E-01 8.16E-01 -9.53E+00
-8.90E-01 -3.09E-01 2.38E-08 -7.53E+00
-8.85E-01 7.22E-01 6.80E-01 -1.05E+01
-8.80E-01 7.22E-01 6.80E-01 -1.40E+01
-8.75E-01 1.55E+00 6.80E-01 -1.10E+01

Time Channel number : 0 Channel number : 1 Channel number : 3
Channel name : Bridge Amplifier Channel name : Voltage Amplifier Channel name : Bridge Amplifier

IM04-0-MFM IM04-0-MFM IM04-0-MFM
User text : TLAK User text : User text : TAH

Recalc. const. Calibrated
Type : Bridge Amplifier Type : Voltage Amplifier Type : Bridge Amplifier
Constant :  MPa 3.99E+03 Constant : 1.00E+00 Constant :  MPa 1.12E+04
FSR: bar 2.49E+02 FSR: V 1.25E+01 FSR: bar 7.02E+02
Range (FSR) : V 6.25E-03 Range (FSR) : V 1.25E+01 Range (FSR) : V 6.25E-03
Filter : kHz 5 Filter : kHz 500 Filter : kHz 1
DC Shift : V -1.28E-01 DC Shift : V -3.00E-02 DC Shift : V -2.00E-03
OCS : uA 5.74E+00 OCS : uA 0.00E+00 OCS : uA -3.67E+00
Excitation Type : Voltage Excitation Type : Off Excitation Type : Voltage
Excitation :  V 6.00E+00 Excitation :  V 1.00E+01 Excitation :  V 1.00E+01
Sensitivity mV/V 1.67E+00 Value 1.00E+00 Sensitivity mV/V 1.78E+00
Sensor range  bar/V 4.00E+01 Sensor range  bar/V 2.00E+02
Sensor resistance Ohm 5.00E+02 Sensor resistance Ohm 4.00E+02

ms bar V bar
5.00E+00 1.51E+00 -6.69E-03 1.59E-01
2.60E+01 5.88E+01 -4.43E-03 1.47E+02
4.70E+01 1.13E+02 -2.91E-03 2.68E+02
6.80E+01 1.15E+02 -6.90E-03 2.78E+02
8.90E+01 1.07E+02 -6.39E-03 2.60E+02
1.10E+02 9.93E+01 -5.45E-03 2.47E+02
1.31E+02 9.58E+01 -8.07E-03 2.41E+02
1.52E+02 9.35E+01 -5.09E-03 2.36E+02
1.73E+02 9.20E+01 -4.65E-03 2.32E+02
1.94E+02 8.94E+01 -5.16E-03 2.28E+02
2.15E+02 8.93E+01 -6.47E-03 2.25E+02
2.36E+02 8.53E+01 -7.41E-03 2.22E+02
2.57E+02 8.47E+01 -5.52E-03 2.19E+02

Example of ASCII exports (imported into MS Excel) 
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File > ASCII Export of report... 
Saving the results in ASCII format on the disk (for transport 
to mathematic or other programs). The user has the option 
to select a standard or user defined data separator The user 
has the option to select a standard or user defined data 
separator. Data format is not described in this manual. In 
case of your interest please contact your dealer or 
developer. 
 
File > ASCII Export of report Rate Of Fire... 
Saving the results of Rate Of Fire in ASCII format on the 
disk (for transport to mathematic or other programs). The 
user has the option to select a standard or user defined 
data separator. Data format is not described in this manual. 
In case of your interest please contact your dealer or 
developer. 
 
File > Excel Export of report... 
Saving the results in MS Excel format on the disk. You can 
directly open this file in MS Excel as a multi-sheet 
document for next mathematical processing. Checkbox 
Export Report Form serves to exporting of Form as a first 
sheet of this document. 
 
File > Excel Export of report Rate Of Fire... 
Saving the results of Rate Of Fire in MS Excel format on 
the disk. You can directly open this file in MS Excel for next 
mathematical processing. 
 
File > Print   Ctrl+P 
Simple printing of actual graph according to printer setting. 
For high-quality printing use clipboard for graph transfer to 
suitable text processor program. 
 
File > Disk info... 
Information about disk drives in the computer (Used, Free) 
and adjusting the minimal free disc space for enable the 
measuring. (Disk space needed for measurement start). 
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File > Report of measured series...    
This button opens the window with round series report. 
 

 
This report contains these parts: 
 the legend with the name of column and with the units 

(top) 
 the column with the round number (left) 
 single column of results, where each one is 

corresponding to line in the window Computing 
 statistic list: average value, standard deviation, 

maximum a minimum value and dispersion (bottom) 
 if velocity is calculated in the column, the average 

kinetic energy is assigned at the bottom (the weight of 
bullet must be inserted in the C.I.P. form window) 
 

The part of report, which is related to electronic target and 
overall statistic, is described in the chapter, which 
describes measurement with the target. 
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File > Report of actual round...    
This button opens the window with listing of basic 
numerical values of current round. 
 
 
 
 
 

The title contains current round number and listing of most 
important results in the window. Each line is corresponding 
to single line in the window Computing. 
 

File > Report of statistics...    
This button opens the window with listing of basic 
numerical values for statistic graph. 
 

The listing contains only maximum of displayed average 
pressure curves. These values are different from middle 
pressure values, assigned in the report of measured series 
by reason of different calculations. 
 
File > Report of Rate Of Fire... 
This button opens the window with listing of report 
Rate Of Fire. 
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File > Final Report...    
This button opens the Final Report window with round 
series report. This report includes customer’s logo and is 
given specially for printing of results. 
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Buttons in Menu Bar serves for: 
 Printing of report 
 Zooming 
 Listing of Pages (First, Previous, Next, Last) 
 Closing of report window 
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Buttons in Tools panel serves for: 
 

 Show/Hide Measurement Form 

 Show/Hide Channel Description 

 Show/Hide Tables 

 Standard Report Table (only main results) or Wide  
          Report Table (all results) 

 Show/Hide Rate Of Fire Table 

 Show/Hide Overall Statistics 

 Show/Hide Graphs 

 Show/Hide Target 

   Portrait or Landscape page 

 Show/Hide Form Grid 
 
 
File > Exit 
This will finish the work with TR 2519 control program. 
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 Menu Edit 3.4.1.2

Edit > Copy   Ctrl + C    
This will make a copy of current graph to the clipboard. 
 

Edit > Delete    
This will delete current round. For permanent delete you 
have to save the data on the disc (the program works only 
with copy of data by reason protection of original data). 
 

Edit > Show point    
It will open the window of zoom and after that it is 
possible to read the coordinates of selected point (they are 
written at the bottom part of Zoom window, moving with 
the cursor is possible by means of the mouse or cursor 
keys). The function is terminated by switching off the 
zoom. 
 
Edit > Move to zero 
This function serves for offset zeroing of measured curves. 
For first round (round No. 1) activate this function and 

select relevant curve by use of magnifying glass . 
By use of cursors select properly area of curve for 
computing of average value (this value is equal to offset). 
After Apply to all, the curve is shifted to zero (removing of 
offset). This action is automatically applied to all shots of 
series. 
If this function is applied on round No. 2 or next, then only 
relevant curve of this active round is shifted. 
For permanent change of data you have to save the data 
on the disc (the program works only with copy of data by 
reason protection of original data). 
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 Menu Calibration 3.4.1.3

    
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Calibration > Activate calibration 
The calibrations are enabled after inserting of password. 
This will open window with calibration protocol listing 
(current calibration constants). There is the new file for 
calibration protocols saving in the directory on the disc. 
This file is labeled with a date and time of calibration 
accessing and is appended step by step with the new data 
of successfully finished calibrations. 
 
Calibration > Deactivate calibration 
The password is deactivated and calibrations are disabled. 
The window with calibration protocol listing is closed and 
the protocol about the calibration, which is on the disc in 
the directory for calibration protocols saving, is closed too. 
The same effect is going after finishing the program, if the 
calibrations were still enabled. 
 
Calibration > All channels offset calibration 
Automatic offset calibration of all channels. Disconnect all 
BNC connectors from the TR 2519 front panel before 
starting calibration. The calibration takes approx. 
20  … 30 minutes and after successful finishing is added 
the new listing of calibration constants. 
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Calibration > Charge amplifier A gain calibration 
Calibration > Charge amplifier B gain calibration 
 
Calibration > Charge amplifier E gain calibration 
Calibration > Charge amplifier F gain calibration 
Manual gain calibration (calibration constant for charge to 
voltage recalculation) of single charge amplifiers. Before 
starting it is necessary to make offset calibration and the 
comparative measuring series with the reference 
instrument or calibrator for each charge amplifier range. 
Determined values are inserted into the table and the 
program calculates correction coefficients for calibration 
constant and they are sent to TR 2519. The new list of 
calibration constants are added to calibration protocol. 
 
Calibration > TR 2519 Calibrator Set 
Setting of TR 2519 Calibrator output voltage (DC or 
pulsed). 
For detailed information see chapter TR 2519 Calibration. 
 
Calibration > TR 2519 Calibrator Reset 
Reset of TR 2519 Calibrator. 
For detailed information see chapter TR 2519 Calibration. 
 
Calibration > TR 2519 Auto Gain Calibration 
Auto-calibration of TR 2519. 
For detailed information see chapter TR 2519 Calibration. 
 
Calibration > Restore default Calibration (!!!) 
Only for service use !!! Restoring calibration from 
developer. It serves only for TR 2519 function restoration if 
working calibration constants are corrupted. Next you have 
to recalibrate all instrument !!! 
 
Calibration > Target Calibration 
Manual target calibration (setting of the X and Y axis gain 
and offset for both target systems). This calibration is 
default for each new measurement. 
For detailed information see User's Guide for Target 
System 2523. 
 
Calibration > TR 2519 Direct Control (!!!) 
Manual control of TR 2519 – only for service use !!! 
 
Calibration > Network 
 
 
 
 
 
 
 
 
 
Setting of network address – it is necessary to set values 
according to the next picture 
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Calibration >Differences 
Special function for visual comparison of pressure curves. 
This function is normally un-accessible – use function 
Activate calibration to make this function accessible. Read 
data file. 
For comparing you can use PRESSURE CURVES ONLY and 
they must be located in the graph of Internal Ballistics. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
Use function Calibration > Differences for displaying of 
window Differences: 
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Control buttons: 
 select Reference Curve - here channel C (Ch2) 
 select Differential Curve : C-A hidden 
        C-B hidden 

                 C-C un-accessible  
  (C is reference) 
  C-D displayed 

 
 
Use standard buttons      for displaying 
of Differential Curves of another shots. It is possible to use 
clipboard (Ctrl+C) function for easy transport of actual 
graph to next applications: 
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 Menu Measurement 3.4.1.4

Measurement > TR 2519 ... 
The activation of TR 2519 virtual panel for addition of 
another rounds to loaded data of previous measurement, 
from which it is taken complete TR 2519 setting. 
 
Measurement > Report form... 
Edit of report form. 
 
Item for creating, saving and loading of form, which is 
displayed in reports. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

In the next picture there is default blank form: 
 
Form consists of three pages (Group 1,2,3). Each page 
consists of two tables. 
Each table consists of title (<Title>) and twelve rows of 
data description and data. 
 
To run form edit mode press button Edit Form 

  . 
Now it is necessary to enter password Kiwag and then 
form in edit mode is accessible: 
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Description of Report Form window in edit mode: 
Group 1, 2, 3 – pages of form, each contains two tables. 
 
Marked checkbox determines displaying of table in reports.  

 
 
 

 
 
 

 
 
 

<Title> - name of table (text string). Checkbox determines 
displaying of name in reports. 
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Each row of table contains offer of possible data types. 
Click on button for displaying of all data types. 
 

 
 
 
 

Summary of all data types: 
 

 
 

String – one row of text (checkbox determines displaying in 
reports) 

 
 

 

Number general number (checkbox determines displaying 
in reports) 

 
 
 
 
 

Memo – multiline text (checkbox determines displaying in 
reports) 

 
 
 

Bullet Diameter – bullet diameter (number is used in 
calculations and can be put only once, checkbox 
determines displaying in reports) 

 

Bullet Weight – bullet weight (number is used in 
calculations and can be put only once, checkbox 
determines displaying in reports) 

 
 
 
 

Meas. Date – date of measurement (filled automatically at 
start of measurement, can be put only once, checkbox 
determines displaying in reports) 
 
 
 
Meas. Time – time of measurement (filled automatically at 
start of measurement, can be put only once, checkbox 
determines displaying in reports) 
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Each row of table contains two parts: 
 name of row (in normal mode inaccessible, here is 

description of data) 
 data (in normal mode accessible for filling with data) 
 
Fill step by step all form. Then you can continue to: 
 

  Save – saves form to disc. 
 

  Load – load form from disc. 
 

  – accepts all changes without saving form to  
                         disc and close the form window. 
 

  – cancels all changes without saving form to  
                         disc and closes the form window. 
 
By means of those functions it is possible to create set of 
standard forms. In the future you can easy load required 
form from the disk – it will save a lot of time. 
 
On the next page there is example of completed form: 
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Next functions (connected to Target System): 
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3.4.1.4.1 Target Background 

 
In Edit Mode of Report Form add this row to your Report 
Form 
 

and save this new Report Form by means of Save button. 
 
Start new measurement. Load your Report Form which 
contains Target Background row and by means of button 

 search for Target Background picture (.jpg type): 
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The target picture will contain selected background: 

 

 

Note 1 
No Target Background after moving of data to another 
computer. 

 
Target Background is not saved with data. If you move 
your data to another computer which does not contain the 
same Target Background picture in appropriate folder, 
target background is clear. To solve this problem use the 
same folder structure and the same Target Background files 
for all your computers. 
 

 

Note 2 
Creating your own Target Background. 

 
Target Background is simply bitmap picture, which fulfills 
next parameters: 
 
 general requirements of JPEG bitmap picture (.jpg) 
 size 2 000x2 000 points (it represents 1 000x1 000 mm  

target - resolution is 2 pixels/mm) 
 save file as .jpg file with low compression ratio (quality 

factor >90 %) 
 
For creating of Target Background you can use: 
 
 vector drawing software (AutoCad, Corel Draw etc.) 
 Use square sheet 1 000x1 000 mm, draw your target in 

1:1 scale and export picture as JPEG bitmap (.jpg) 
picture with resolution 2 000x2 000 points 

 
 bitmap drawing software (Corel PhotoPaint, Adobe 

PhotoShop etc.) 
Use square sheet 2 000x2 000 points, draw your target 
and save picture as JPEG bitmap (.jpg) picture with 
resolution 2 000x2 000 points. Instead of drawing you 
can use scanned original paper target too (but be 
careful to keep relevant scale and resolution 
2 pixels/mm)  
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 Real Diameter of Hits and Shot Numbers in Target Picture 3.4.1.5

 
 
 
Enter real diameter of bullet in this row of Report Form. 
 
Then in menu C 7.1.7 Menu Settings select 
Preferences > Misc use checkboxes: 
 
 Visible Shot Numbers (to show or hide of shot numbers 

in target picture)  
 Real Bullet Sizes (diameter of hit in target picture 

corresponds to real bullet diameter)  
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 Menu Graphs and Computing 3.4.1.6

Graphs and computing > Chart Int  Ctrl+F1 

 
Graphs and computing > Chart Ext 1  Ctrl+F2 

 
Graphs and computing > Chart Ext 2  Ctrl+F3 

 
Graphs and computing > Statistics  Ctrl+F4 

                   Selection of graphs. 
 
 
Graphs and computing > Zoom    
Activation and finishing of zoom function. Selection of 
displayed curve is possible by means of small icons of 
magnifying glass at the number of displayed curves in the 

left part of main program window ( ). 
 

Graphs and computing > Lock X    

Graphs and computing > Lock Y    
 
Activation and deactivation of zoom lock for X and Y 
cursors. (right and left, resp. top and bottom cursors are 
moved at the same time). 
 

Graphs and computing > Target No. 1, 2      
Activation of target window 1 and 2. 
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Graphs and computing > Computing 
Activation and deactivation of computing window 

 
C.I.P. and NATO Correction of results 
C.I.P. correction is used for computing of corrected statistic 
results. 
Each single measured value in table is untouched. 
Report contains at the end these results : 
 
CIP K:  value of C.I.P. coefficient 
Avg +: corrected value  
  [Avg +] = [Avg] + [CIP K] x [SD] 
Avg -: corrected value 
  [Avg-] = [Avg] – [CIP K] x [SD] 
 
where SD means Standard Deviation. 
 
NATO Correction is used for correction of each measured 
value in table: 
 
Value in table   =   Measured value + NATO Correction 
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This menu serves for building the method for evaluation of 
measured data, i.e. for numerical calculations of time, 
velocity, gradient and integral of any curve. By contrast to 
other analyzers it is not prearranged, what the instrument 
measures, but the user can adjust TR 2519 according to its 
requirements for concrete application. 
 
Common instructions for working in this window are: 
 the line is selected by means of button with colored 

number of curve. 

 go to edit mode by means of button  Edit , for 

finishing press button  Apply to all or  
Escape . 

 use the key ENTER for numerical value or text inserting 
or move cursor to another field for number/text 
inserting or the new value will not be accepted 

 all editing of data are accessible only for first round 
series and the change is applied always for all the others 
after pressing Apply to all or will be canceled after 
pressing Escape 

 for second and another rounds it is possible to edit only 
vertical cursors setting (they determine the interval for 
evaluation) and horizontal cursor (threshold setting) 

 detailed description of cursor setting and the practice 
are assigned on the measurement example, see chapter 
B 4.4 Creating of method for data evaluation 
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Add Time/Velocity – calculation of time and velocity 
The single elements are (from the left): the line number, 
the checkbox for show/hide row in all reports, the icon for 
marking of function, the button for start a time 
admeasurement (up), the button for stop of time 
admeasurement (down), setting of horizontal cursor unit 
([%] of maximum value or Y-axis unit [V, bar,…] ), the 
button for selection of rise/fall edge from left/right for start 
(up) and stop (down), entering of minimum acceptable 
width of start (up) and stop (down) impulse, the text field 
for any line marking, the result of time admeasurement 
(start – stop), the checkbox for selection of velocity 
calculation, setting of the distance of first gate of pair from 
the muzzle (up), setting the size of base (distance between 
pair of gates, down), the final value of velocity, the 
checkbox for selection of calculation with limits, entering of 
maximum (up) and minimum (down) limit value, the 
checkbox for selection of calculation with C.I.P./NATO 
coefficients and the field for setting of C.I.P./NATO 
coefficient. 
 
 
 
 
 
Add t/v integral – calculation of time and velocity by 
means of integral 
The setting is in Settings > Preferences > Misc > Integral. 
This using requires special analog optical gates, which 
allow this TR 2519 calculating with the center of flying 
object (setting basic calculates integral of shadow, i.e. 
projection of the bullet, square calculates integral of 
shadow square, i.e. through-flying mass). In selected 
interval it is always pictured the integral curve and it is 
calculated its intersection with horizontal cursor. It is 
pictured position of horizontal cursor in percent from the 
maximum of integral. 
The single elements are (from the left) : the line number, 
the checkbox for show/hide row in all reports, the icon for 
marking of function, the button for start a time 
admeasurement (up), the button for stop of time 
admeasurement (down), the text field for any line marking, 
the result of time admeasurement (start – stop), the 
checkbox for selection of velocity calculation, setting of the 
distance of first gate of pair from the muzzle (up), setting 
the size of base (distance between pair of gates, down), 
the final value of velocity, the checkbox for selection of 
calculation with limits, entering of maximum (up) and 
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minimum (down) limit value, the checkbox for selection of 
calculation with C.I.P./NATO coefficients and the field for 
setting of C.I.P./NATO coefficient. 

 
 

 
 
Add t/v zero – calculation of velocity from zero crossing 
The single elements are (from the left) : the line number, 
the checkbox for show/hide row in all reports, the icon for 
marking of function, the button for start a time 
admeasurement (up), the button for stop of time 
admeasurement (down), setting of horizontal cursor unit 
( [%] of maximum value or Y-axis unit [V, bar,…] ), the 
button for acceptance of first crossing by zero after 
exceeding threshold level from the left or from right for 
start (up) and stop (down), entering of minimum 
acceptable width of start (up) and stop (down) impulse, 
the text field for any line marking, the result of time 
admeasurement (start – stop), the checkbox for selection 
of velocity calculation, setting of the distance of first gate 
of pair from the muzzle (up), setting the size of base 
(distance between pair of gates, down), the final value of 
velocity, the checkbox for selection of calculation with 
limits, entering of maximum (up) and minimum (down) 
limit value, the checkbox for selection of calculation 
with C.I.P./NATO coefficients and the field for setting of 
C.I.P./NATO coefficient. 
 
 
 
 
 
Add pressure - calculation of the maximum pressure 
The single elements are (from the left) : the line number, 
the checkbox for show/hide row in all reports, the icon for 
marking of function, the button for start a time to 
maximum admeasurement (up), the button for setting of 
interval for maximum pressure calculation (down), setting 
of horizontal cursor unit ( [%] of maximum value or Y-axis 
unit [V, bar,…] ), the button for selection of rise/fall edge 
from left/right for start (up), entering of minimum 
acceptable width of start impulse (up), setting of length of 
noise filter for calculation of maximum value (down), the 
text field for any line marking, the result of time 
admeasurement (up) and maximum pressure (down), the 
checkbox for selection of time up to adjusted pressure 
level, setting the pressure level in percent of maximum 
pressure, the final time up to specified pressure level, the 
checkbox for selection of calculation with limits, entering of 
maximum (up) and minimum (down) limit value, the 
checkbox for selection of calculation with C.I.P./NATO 
coefficients and the field for setting of C.I.P./NATO 
coefficient. 
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Add Y = f (X) – computing of function value for preset 
value of X(time) 
The single elements are (from the left) : the line number, 
the checkbox for show/hide row in all reports, the icon for 
marking of function, the button for selection of the curve, 
the text field for any line marking, value of preset X 
coordinate (time, up) and computed relevant value Y, the 
checkbox for selection of calculation with limits, entering of 
maximum (up) and minimum (down) limit value, the 
checkbox for selection of calculation with C.I.P./NATO 
coefficients and the field for setting of C.I.P./NATO 
coefficient. 
 

Add adv. Y = f (X) – computing of function value at start 
impulse 
The single elements are (from the left) : the line number, 
the checkbox for show/hide row in all reports, the icon for 
marking of function, the button for selection of start 
impulse, setting of horizontal cursor unit ( [%] of 
maximum value or Y-axis unit [V, bar,…] ), the button for 
selection of rise/fall edge from left/right, entering of 
minimum acceptable width of impulse, the text field for 
any line marking, value of relevant X coordinate (time), 
selection of curve for computing of Y coordinate, 
computed relevant Y-value, the checkbox for selection of 
calculation with limits, entering of maximum (up) and 
minimum (down) limit value, the checkbox for selection of 
calculation with C.I.P./NATO coefficients and the field for 
setting of C.I.P./NATO coefficient. 
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Add Y = AVG (X) – computing of average value of 
function in interval X 
The single elements are (from the left) : the line number, 
the checkbox for show/hide row in all reports, the icon for 
marking of function, the button for selection of the curve, 
the text field for any line marking, value of preset X 
interval (time, up) and computed relevant value 
Y=AVG(X), the checkbox for selection of calculation with 
limits, entering of maximum (up) and minimum (down) 
limit value, the checkbox for selection of calculation 
with C.I.P./NATO coefficients and the field for setting of 
C.I.P./NATO coefficient. 

 
 
 

 
Add integral – calculation of integral (between cursors) 
The single elements are (from the left): the line number, 
the checkbox for show/hide row in all reports, the icon for 
marking of function, the button for setting the limits of 
integration, the text field for any line marking, the result of 
integration time admeasurement (up) and the final value of 
integral (down), the checkbox for selection of calculation 
with limits, entering of maximum (up) and minimum 
(down) limit value, the checkbox for selection of 
calculation with C.I.P./NATO coefficients and the field for 
setting of C.I.P./NATO coefficient. 

  



 Data Evaluation and Reference Manual Transient Recorder Type 2519A… 

Page 58  2519A_002-607e-10.12 

 
 
 

 
Add adv. integral – calculation of integral (between 
start/stop impulse) 
The single elements are (from the left) : the line number, 
the checkbox for show/hide row in all reports, the icon for 
marking of function, the button for selection of start 
impulse (up), the button for selection of stop impulse 
(down), setting of horizontal cursor unit ( [%] of maximum 
value or Y-axis unit [V, bar,…] ), the button for selection of 
rise/fall edge from left/right for start (up) and stop (down), 
entering of minimum acceptable width of start (up) and 
stop (down) impulse, the text field for any line marking, 
the result of integration time admeasurement (start – stop), 
the selection of curve for integration, the final value of 
integral, the checkbox for selection of calculation with 
limits, entering of maximum (up) and minimum (down) 
limit value, the checkbox for selection of calculation 
with C.I.P./NATO coefficients and the field for setting of 
C.I.P./NATO coefficient. 

 
 
 

 
Add gradient – calculation of rate of rise (rate of fall) of 
the curve 
The single elements are (from the left) : the line number, 
the checkbox for show/hide row in all reports, the icon for 
marking of function, the button for setting the calculation 
limits, the text field for any line marking, the result of 
derivation time admeasurement (up) and the final value of 
rate of rise (rate of fall, down), the checkbox for selection 
of calculation with limits, entering of maximum (up) and 
minimum (down) limit value, the checkbox for selection of 
calculation with C.I.P./NATO coefficients and the field for 
setting of C.I.P./NATO coefficient. 
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Add Rise/Fall – computing of parameters of impulse edge 
(rate of rise, rate of fall) 
The single elements are (from the left) : the line number, 
the checkbox for show/hide row in all reports, the icon for 
marking of function, the button for selection of the curve, 
the button for setting the calculation limits, the button for 
selection of rise or fall edge, setting of horizontal cursor 
unit ( [%] of maximum value or Y-axis unit [V, bar,…] ), 
switch for selection of limits (% of maximum value, direct 
value), entering of the limit values for searching of start 
point (down) and stop point (up) of linear approximation 
of impulse edge, the text field for any line marking, 
computed value of dX (up) and dY (down), the final value 
of linear approximation of rate of rise (rate of fall) dY/dX, 
the checkbox for selection of calculation with C.I.P./NATO 
coefficients and the field for setting of C.I.P./NATO 
coefficient. 
 
This function serves for determinate of impulse rate of rise 
(rate of fall) by means of linear approximation between 
two points, which are computed as a percent of percent of 
value of maximum in selected interval. 
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Add Mask – mask for checking of shape of curve 
The single elements are (from the left) : the line number, 
the checkbox for show/hide row in all reports, the icon for 
marking of function, the button for selection of the curve, 
the text field for any line marking and the buttons for 
setting of high and low limit mask. After pressing of button 
appears the table for entering of mask, where first column 
means time coordinate (X axe) and second column means 
value of measured signal (relevant axe Y). Handling of the 
table is described in help (at the bottom of table). After 
activation of this row in Computing window the relevant 
mask is highlighted. Buttons Load and Save serve for 
loading and saving of created mask. Relevant tables are 
written in reports. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Button  in main program window toolbar serves for 
displaying (hiding) of selected mask in main program 
window or statistic window. Number of mask corresponds 

with relevant number of row in computing . 
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Add Rate Of Fire – calculation of Rate Of Fire 
The single elements are (from the left) : the line number, 
the checkbox for show/hide row in all reports, the icon for 
marking of function, the button for searching of start 
impulses (up), the button for searching of stop impulses 
(down), setting of horizontal cursor unit ( [%] of maximum 
value or Y-axis unit [V, bar,…] ), the button for selection of 
rise/fall edge from left/right for start (up) and stop (down), 
entering of minimum acceptable width of start (up) and 
stop (down) impulse, the text field for any line marking, 
the result value of Rate Of Fire (average value), the 
checkbox for selection of velocity calculation, setting of the 
distance of first gate of pair from the muzzle (up), setting 
the size of base (distance between pair of gates, down), 
the final value of velocity (average value), the checkbox for 
selection of calculation with limits, entering of maximum 
(up) and minimum (down) limit value, the checkbox for 
selection of calculation with C.I.P. coefficients and the field 
for setting of C.I.P. coefficient. 
 

 
Add target – calculation of target 
The single elements are (from the left) : the line number, 
the checkbox for show/hide row in all reports, the icon for 
marking of function, the button for searching of X impulses 
(up), the button for searching of Y impulses (down), 
setting of horizontal cursor unit ( [%] of maximum value or 
Y-axis unit [V, bar,…] ), the button for selection of rise/fall 
edge from left/right for X (up) and Y (down), entering of 
minimum acceptable width of X (up) and Y (down) 
impulse, the text field for any line marking, the result of 
coordinate X (up) and Y (down), the checkbox for selection 
of target velocity calculation, setting of the distance of first 
gate of pair from the muzzle (up), setting the size of base 
(distance between pair of gates, down), the final value of 
velocity, the checkbox for selection of calculation with 
limits, entering of maximum (up) and minimum (down) 
limit value, the checkbox for selection of calculation 
with C.I.P./NATO coefficients and the field for setting of 
C.I.P./NATO coefficient. 
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Add user – input of any numeric value 
This value will be processed with data. 
The single elements are (from the left) : the line number, 
the checkbox for show/hide row in all reports, the icon for 
marking of function, the text field for any line marking, the 
field for setting the numerical value, the checkbox for 
selection of calculation with C.I.P. coefficients and the field 
for setting of C.I.P. coefficient. 
 
 

 
Add Start-Stop Counter – computing of time/velocity by 
means of counters (BA04SE only) 
The single elements are (from the left) : the line number, 
the checkbox for show/hide row in all reports, the icon for 
marking of function, the button for selection of counter 
channel, the text field for any line marking, the result of 
time admeasurement, the checkbox for selection of 
velocity calculation, setting of the distance of first gate of 
pair from the muzzle (up), setting the size of base (distance 
between pair of gates, down), the final value of velocity, 
the checkbox for selection of calculation with limits, 
entering of maximum (up) and minimum (down) limit 
value, the checkbox for selection of calculation 
with C.I.P./NATO coefficients and the field for setting of 
C.I.P./NATO coefficient. 
 

 

 
Add GPS – UTC Time and Coordinates 
The single elements are (from the left) : the line number, 
the checkbox for show/hide row in all reports, the icon for 
marking of function, the text field for any line marking, 
UTC Date and Time, checkbox for adding of GPS 
Coordinates, GPS Coordinates (upper Longitude, lower 
Latitude) and GPS Status for checking of function. 
If GPS module is not present, this function adds date and 
time stamp from Windows and coordinates are empty. 
 

  



Reference Instructions 

2519A_002-607e-10.12  Page 63 

 
 
 

 
Add Calculation – calculation by use of results of previous 
rows 
The single elements are (from the left) : the line number, 
the checkbox for show/hide row in all reports, the icon for 
marking of function, the text field for any line marking, the 
field for entering of formula, the result of computing, the 
checkbox for selection of calculation with limits, entering of 
maximum (up) and minimum (down) limit value, the 
checkbox for selection of calculation with C.I.P./NATO 
coefficients and the field for setting of C.I.P./NATO 
coefficient. 
 
Valid formula elements : 
Rn   = result of row number n (R2 etc.) 
Dn   = row number n, distance of first 
      velocity gate (D5 etc.)   

       
Bn   = row number n, base for measuring of 

      velocity (B4 etc.)     
Abs(x)  = absolute value of a number x 
Sqr(x)  = square of a number x 
Sqrt(x)  = positive square root of a number x 
Round(x)  = rounded value of a number x 
Int(x)  = integer part of a number x 
Sin(x)  = sine of an angle x 
Cos(x)  = cosine of an angle x 
Tan(x)  = tangent of an angle x 
Arctan(x)  = arctangent of a number x 
Ln(x)  = natural logarithm of a number x 
Log(x)  = base-10 logarithm of a number x 
Log2(x)  = base-2 logarithm of a number x 
Exp(x)  = e raised to the power of a given 
      number x 
Pi   = value of Pi 
+   = addition 
-   = subtraction 
*   = multiplication 
/   = division 
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– Delete row – delete selected row 
 

– Delete all – delete all rows 

 
– Edit – switching of selected row to edit mode 

 
– Apply to all – exit from edit mode and 
saving changes (for all round of series) 

 
– Apply – exit from edit mode and saving 
changes for current round 

 
– Escape – exit without saving 

 
– Up, Down – selected line feed  

       up/down 
  
 
Graphs and computing > Group 
Organizer    
The function for allocation of rounds to the groups. 
 
 
Graphs and computing > Series 
Organizer    
The function for assigning of channels to relevant graphs - 
see next picture: 
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Graphs and computing > Filter   
These filters serve to suppression of noise. It is possible to 
use this filter immediately during measurement or late after 
measurement. Original data is always retained and data is 
automatically restored after switch-off filter. 

Filter is activated by use of button  or in menu Graphs 
and computing > Filters. It appears the window (Pic 36), 
which contains setting of running average filter for each 
channel: 
 checkbox of filter activation 
 setting of filter parameters (number of points for 

computing of average value - higher number increases 
efficacy of filtering, but increases distortion of curve). 
Maximum number of points for computing of average 
value is limited to 1 % of all measured points of 
relevant curve 

 
Channels filtered during measurement are color marked. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 Menu Select 3.4.1.7

 
 
 
 
 
 
 
 
 
 

This menu copies the function of 
buttons and it serves for round 

selection within the series. Select > First, Previous, Next, 
Last. 
Their function is (from the top / left): first round, previous 
round, direct selection, next round and last round. 
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 Menu Settings 3.4.1.8

 
 
 
 
 
 
 
 
 
The menu contains basic program setting – directories and 
preferences. 
 
 
 

 Data   - measured data  
 ASCII export  - data output in ASCII form 
 Settings (Methods) - TR 2519 setting (methods) 
 Reports   - measured results in the                

                                         protocol forms 
 XLS Reports  - measured results in the XLS  

                                         protocol forms 
 Calibrations  - calibration protocols 
 References  - reference curves 
 Report Forms  - C.I.P. forms 
 Sensors   - sensors for TR 2519 
 Target Background - target backgrounds (jpg files) 
 Data Backup  - directory for data backup 
 Temporary  - temporary files 



 Data Evaluation and Reference Manual Transient Recorder Type 2519A… 

Page 68  2519A_002-607e-10.12 

 
 
 
 
 
 
 
 
 
 
 
 
 
Series contains setting of the colors of curves and their 
numbering. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Graph colors contains setting of the colors of graph 
elements: graph background (Background), gridlines 
(Gridlines), the marks of triggering time (Trigger line), 
cursor lines for zoom limitation (Zoom lines), highlighting 
of selected area (Selected area), border of mask (Mask 
border) and marking of filtered channels (Filtered series). 
Line size series is setting of graph lines width. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Target contains setting of the colors of target elements. 
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Groups contain setting of the colors of groups. 
If checkbox Use group colors is checked then in graph 

Statistics  are used these colors for each group instead 
of different color for each channel. This function is 
determined for visual comparison of different groups of 
ammunitions etc. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Scales – contains setting of Y-axes scales. The selection 
Auto makes axis dimensioning according to relevant 
founded curves maximum and minimum. To set of fixed 
scale, uncheck the selection Auto and fill minimum and 
maximum axe value. The option of automatic axes setting 

can be temporary activated by means of the button . 
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Units contain settings of length, pressure and weight units. 
Decimals contains settings of numeric format (decimals). If 
value is out of range (Minimum/Maximum), then it will be 
displayed in exponential form. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Axes contains settings of distance between right axes and 
font size. 
  Target axes fixed range sets scale of target after using 

of button Fixed. 
Report is reserved for settings of reports. 
Report type decides, what type of reports will be generated 
to preset directory Reports directory: 
  Single: only short report in primary language 

localization 
  Multiple: 

 1st long + 1st short (long and short report in 
primary language localization) 

 2nd long + 2nd short (long and short report in 
secondary language localization) 

Text report type – selection of displayed report. 
2nd report localization – selection of secondary language 
localization (for writing of secondary reports in different 
language – restart of program required). 
Column sizes, Font sizes – selection width of report 
columns and fonts (titles, data). 
AUTO report, AUTO actual report sets automatic opening 
of reports at measurement. 
XLS report determines automatic generating of report in 
XLS form and file extension.  
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Misc is reserved for special program functions: 
Integral is the special option for calculating with the center 
of flying object (setting basic calculates integral of shadow, 
i.e. projection of the bullet, square calculates integral of 
shadow square, i.e. through-flying mass). This 
function has influence only for calculations 
in Computing >. 
Target computing method is selection of electronic target 
data evaluation method (default choice is Statistical, for 
special use is determined Graphical – see relevant chapter 
about measurement of accuracy by means of Target 
System WTS03). 
Overall target statistics determines calculation of 
Overall target statistics (default choice All rounds calculates 
it from all rounds regardless of division to groups, 
Group statistics calculates overall target statistics from all 
partial group statistics (for special use only)). 
Localization – selection of primary language localization 
(restart of program required). 
Auto date serves for automatic inserting of date (in form 
YYYY-MM-DD) before name of measurement – data on 
disc are easy sorted by date of measurement. 
Auto from start enables access to button AUTO at start of 
measurement (unchecked make this accessible after first 
round). 
Visible Shot Numbers enables numeration of hits in target. 
Real Bullet Sizes enables real hit diameter in target 
according to bullet diameter. 
 
Export for SHOT is custom option for special program 
mode and must be always inactive! 
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Final Report contains set of tools for customizing of Final 
Report. 
 Report Logo sets path to user's logo. 
 

 Menu Help 3.4.1.9

 
 

 
 

About contains information about the program version. 
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3.4.2 TR 2519: Panel of Virtual TR 2519 

 
 
 
 
 
 

This panel controls all functions during measurement. It is 
built from the common upper part and from the panels of 
input modules in the lower part. 
 

 

 
 
 
 
 
 
 
 
 
 

 
 
 
 
Sampling rate (Sample Rate) determines the number of 
points of input signal (pressure etc.), which are recorded 
for every second. Its setting has effect for density of points 
on the final graph. Too high density made data processing 
slower and the large files are created on the disk. 
According to C.I.P. specifies the minimal sampling rare 
1MHz, which is a standard method in practice for pressure 
measuring of powder gases.  
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Trigger level (Trigger Level) is the specific value. After 
exceeding this value the TR 2519 data recording is 
initiated. This value is pictured in percent of given range. 
For negative values has blue color, for positive values has 
red color and for zero value has green color. Set optimal 
trigger value for secure triggering without possibility of 
false triggering caused by noise and interference (and that 
is why the level 0.00% is not used during pressure 
triggering). Recommended value for typical measuring is 
12,5 %. 
 
Trigger edge (Trigger Edge) determines, while data 
recording initialization will be followed after trigger level 
exceeding (Trigger Level) during signal increasing (RISE) or 
during signal decreasing (FALL). 
 
 
    
 
 
 
These buttons serve for Transient Recorder setting 
(Settings) and make loading possible (LOAD) and saving 
(SAVE) on the control computer disk. Detailed description – 
see relevant text. 
 

 
Virtual TR 2519 display provides important information 
about the setting and TR 2519 measuring procedure. There 
is the name of directory on the left topside in the first row 
(Name, Series), where this data will be stored, and the 
volume of total saved data in this series (Saved Data). 
There is the round counter on the right topside (Round), 
the number 0 means, that neither round was recorded so 
far. 
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For understanding of function of other settings it is 
necessary explaining TR 2519 operation with the memory 
of AD converters. This memory is always filled with data in 
the range –100 000 to +300 000 points. The negative 
numbers are the so-called pretrigger, i.e. the data which 
are recorded before recording initiation, zero is the time of 
triggering and positive numbers are data after recording 
initiation. For typical work are 400 000 points too many 
and that is why only required part of data are transferred 
to control computer. This part is set-up separately for every 
pair of channels A(CH0)+B(CH1), C(CH2)+D(CH3), 
E(CH4)+F(CH5) and G(CH6)+H(CH7) (see chapter 
B 3.3 Recommendations for choosing and using single 
channels (inputs)) The beginning of memory reading is 
located on the left part of display, the end is on the right. 
The adjusted data are displayed for checking by bar graph 
form. The vertical red line indicates time of triggering 
(Trigger point). 
In the second line of display are written calculations of 
transported points and lengths of time intervals for every 
pair of channels (Record) and total volume of data for the 
one round. 
Free horizontal line in the center of display is used for bar 
graph displaying with data transport process from TR 2519 
to control computer. 
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There are the buttons for TR 2519 measuring control in 
the right part of virtual TR 2519 panel. Their functions are: 
delete last round (DELETE), run measuring (RUN), stop 
measuring (STOP), automatic measuring of the whole 
series (AUTO) and testing of inputs (TEST). The button 
RUN has second function READ (for reread of TR 2519 
data after modification of time intervals at first round of 
series) and the button STOP has second function BREAK 
(interrupt of long measurement by using low sample rate). 
The function of those buttons will be described later during 
measuring. 
 

 
Window TEST – reading of signal at all channels of TR 
2519 in actual units (first row) and voltages at inputs of 
ADC (max. ±5 V, second row). 
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The panel of input module – charge amplifier. 
A CH0 – the marking of channel, color is the same as color 
of curve in graph. 
Charge amplifier IM06-0-CHGA – the name of module. 
Four lines of free text – text filled for placing description of 
relevant channel for better orientation of user (sensor type, 
it’s using, location on the weapon i.e.). 
Trigger – the switch for the trigger channel selection. 
Selected channel is highlighted with the red color. We 
recommend to choose the pressure channel as the 
triggering source, because by contrast to accelerometer it 
provides clear course with defined and almost constant 
shape and it is very resistive against the false triggering. 
Setting of calibration constant of sensor – button for 
setting of the pressure sensor calibration coefficient. For 
entering of sensor coefficient press this button and select 
item from menu: 
 Load is for loading of saved sensor parameters 
 Save is for saving of actual sensor parameters 
 Parameters serves for direct entering of sensor 

parameters in exponential form (button Inverted inverts 
the sensor polarity - for sensors with negative 
calibration coefficient let this button inactive). [pC/?] 
means user defined unit (different from previously 
defined) 

 Range 2 600 pC, 5 200 pC, 10 600 pC, 20 200 pC – 
the selection of measuring range. Beside the title Range 
is displayed calculated value of measuring range in bar 
units (depends on the selection of measuring range and 
on the sensor calibration coefficient  

 provides information about true maximum pressure) 
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Filter 10 kHz, 20 kHz, 40 kHz, Off – the filter selection. 
Auto-zero on, Auto-zero off – the switch of automatically 
compensation of the offset and the cable leakage. 
Normally use only Auto-zero on, do not set this switch to 
Auto-zero off. This provides maximum measuring accuracy 
by changing of temperature and other ambient conditions. 
Only for measuring of pressure process which are longer 
than 100 ms it is necessary to disable this function (Auto-
zero off), because compensation causes distortion of 
measurement. 
Apply – serves to send of actual settings into TR 2519. 

 
 
The panel of input module – universal voltage input. 
E CH4 – the marking of channel, color is the same as color 
of curve in graph. 
Voltage input IM07-0-D2SA – the name of module. 
Four lines of free text – text filled for placing description of 
relevant channel for better orientation of user (sensor type, 
it’s using, location on the weapon i.e.). 
Trigger – the switch for the trigger channel selection. 
Selected channel is highlighted with the red color. 
Range 1 V, 2 V, 5 V, 10 V – the selection of measuring 
range. Because this module has three summing inputs, the 
range means sum of three input voltages. 
Apply – serves to send of actual settings into TR 2519. 
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