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Foreword 

Thank you for choosing a Kistler quality product 
characterized by technical innovation, precision and long 
life. 
 
Information in this document is subject to change without 
notice. Kistler reserves the right to change or improve its 
products and make changes in the content without 
obligation to notify any person or organization of such 
changes or improvements. 
 
©2012 Kistler Group. All rights reserved. Except as 
expressly provided herein, no part of this manual may be 
reproduced for any purpose without the express prior 
written consent of Kistler Group. 
 
 
 
Kistler Group 
Eulachstrasse 22 
8408 Winterthur 
Switzerland 
Tel. +41 52 224 11 11  
Fax +41 52 224 14 14 
info@kistler.com 
www.kistler.com 
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1. Introduction 

Please take the time to thoroughly read this instruction 
manual. It will help you with the installation, maintenance, 
and use of this product. 
 
To the extent permitted by law Kistler does not accept any 
liability if this instruction manual is not followed or 
products other than those listed under Accessories are 
used.  
 
Kistler offers a wide range of products for use in measuring 
technology: 
 Piezoelectric sensors for measuring force, torque, strain, 

pressure, acceleration, shock, vibration and acoustic-
emission 

 Strain gage sensor systems for measuring force and 
torque 

 Piezoresistive pressure sensors and transmitters 
 Signal conditioners, indicators and calibrators 
 Electronic control and monitoring systems as well as 

software for specific measurement applications 
 Data transmission modules (telemetry) 
 
Kistler also develops and produces measuring solutions for 
the application fields of engines, vehicles, manufacturing, 
plastics and biomechanics sectors. 
 
Our product and application brochures will provide you 
with an overview of our product range. Detailed data 
sheets are available for almost all products. 
 
If you need additional help beyond what can be found 
either on-line or in this manual, please contact Kistler's 
extensive support organization. 
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2. Important Information 

2.1 Disposal Instructions for Electrical and Electronic Equipment 

 
Do not discard old electronic instruments in municipal 
trash. For disposal at end of life, please return this 
product to an authorized local electronic waste disposal 
service or contact the nearest Kistler Instrument sales 
office for return instructions. 

 

2.2 Software Upgrades and Updates 

Kistler may from time to time supply upgrades or updates 
for embedded software. Such upgrades or updates must 
always be installed.  
 
Kistler declines any liability whatsoever for any direct or 
consequential damage caused by products running on 
embedded software which has not been upgraded or 
updated with the latest software supplied. 
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3. Basic Characteristic of TR 2519 

Kistlers' measurement and data evaluation philosophy are 
the difference between ours and other ballistic analyzers on 
the market. 
 
Standard analyzers are produced with rigid input 
configurations and limited measurement capabilities, which 
creates a high expense for any changes needed. 
 
The Kistler analyzer, is fully customizable and has no fixed 
input configuration, making it easily adaptable for current 
and future applications.  A nearly unlimited number of 
ballistics applications are possible, thanks to the Windows® 
based evaluation method. 
 

 

Fig. 1: Transient recorder Type 2519A... 

 
The Transient Recorder Type 2519 was developed to fill 
the need for an energy efficient compact unit that provides 
maximum flexibility.  
 
The following comparison chart points on the considerable 
differences in construction from the limited conventional 
ballistic analyzers and the Kistler Type 2519: 
 
 
 
 

 
 
 
 
 
 
 
 
 
Microsoft Windows® is a registered trade mark of Microsoft Corporation. 
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3.1 Structural Design of Transient Recorder 

 The standard conventional BA's are formed from the 
special PC card (this using requires desktop PC). This 
card is connected with external block of charge 
amplifiers and with the next adaptors. The pressure 
measuring is performed by means of two channel AD 
converter with memory, the velocity measuring is 
performed by means of start/stop counter. The signal 
processing for start/stop signal generating (mostly 
impulses from optical gates) and for initiating of 
measuring by means of accelerometer make the 
trouble, because the input modules are sensitive for 
signal quality and for correct threshold adjusting. The 
diagnostics is complicated because BA do not make 
course of signal viewing possible from digital inputs and 
that is why it is necessary using a digital oscilloscope. 
This increase the costs of BA operation and through-
going check during firing is problematical. The number, 
type and channels using is fixed by instrument design 
and this will make only standard measuring possible 
(designated by producer) 
 

 This TR 2519 is compact small instrument, which is built 
from block of power supplies and from industry 
computer of miniature dimensions, from eight identical 
AD converters (next only ADC) and from eight 
removable input cards. The instrument control is 
provided via Ethernet connection from PC compatible 
(desktop, notebook, panel PC). The measuring of up to 
four pressure courses is performed by means of first 
quad of ADC and charge amplifiers. The next four ADC 
are used for connecting of miscellaneous voltage signals 
(accelerometer, muzzle sensor) or for measuring of 
velocity/accuracy by means of up to six gates. The 
gates may have digital or analog output (this can be 
used for display of bullet pass through the gate). Every 
TR 2519 channels saving input courses of digital and 
analog signals and that is why TR 2519 replacing 
diagnostic instruments incl. digital oscilloscope and 
make more easy failure localization possible during 
working operation. Channel using is not given sternly 
and this provides for user higher variability in method 
connection and used sensors 
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3.2 Mobility and Power Supply Possibilities 

 Standard BA is usually a large instrument (incl. desktop 
PC) and so the mobility and terrain using is 
problematical. Excessive shock proof is also usually bad. 
Power supply is possible only from electricity line and 
power consumption reduces instrument using in terrain  

 TR 2519 is designed for mobile using - small 
dimensions, resistance against the shocks, internal air 
circulation and so resistance against the dust, small 
power consumption 30 W at 12 V (24 V version is 
possible according to customer request). Notebook is 
best way for mobile using as control computer, but 
thanks to Ethernet connection (galvanic isolated 
connection) it is possible to use any computer with 
Ethernet card 

3.3 Transient Recorder 2519 Control 

 The functions are controlled partial manually and partial 
from control program. So it is impossible instrument 
adjustment according to method, which is stored on the 
control computer disc. The requirements for operating 
personnel are higher and possibility making mistake 
during measuring or during instrument configuring is 
also high 

 All functions in TR 2519 are called from virtual machine 
in MS Windows® environment. User friendly 
environment make possible several ways for saving 
complete TR 2519 configuration including data 
evaluation method and output protocol format 
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3.4 Graphical and Numerical Data Evaluation and Output Protocol 
Format 

 The software does not provide many ways for 
performing alternative data evaluations than standard 
thanks to fixed hardware configuration and output 
protocol about shooting is also given 

 A different approach has been choosen for this 
instrument thanks to its connection variability to the 
system. The first there are configured basic parameters 
(sampling rate, triggering conditions, charge amplifiers 
ranges) and the single round is fired out. According this 
shot it is performed the setting of required calculations 
between any channels and final method is stored on the 
disc for future measuring. It is also possible shooting the 
whole shot series during continuous numerical outputs 
checking. The correction of calculations setting is 
possible during shooting, after shooting and in the 
future. The difference between standard process and 
this process is in the possibility to correct conditions for 
shot calculation, when the threshold setting for velocity 
measuring was incorrect. The shot is lost in 
conventional system. The data in output protocol about 
shooting are changed in dependence on the calculation 
settings. The protocol is available in three forms - full 
and short for all shots and short for current shot. The 
truncated protocol is generating directly in Microsoft® 
Word format 

3.5 Calibration 

 The manufacturers are not usually interesting in 
production of calibration instruments for charge 
amplifiers or they are making devices for manual 
calibration. So the calibration process is exacting for 
control and takes a several hours of work 

 The TR 2519 has implemented manual calibration of 
charge amplifiers and automatic offset calibration of all 
inputs. Thanks to connection with 6-channel charge 
calibrator QC04 it is able calibrating automatically all 
charge amplifiers during 30 minutes. The protocol is 
generating about every calibration process and it is 
stored on the control computer disk 
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4. User Manual 

4.1 List of Used Abbreviations and Terms 

TR 2519 Transient Recorder Type 2519 
 
BA Ballistic Analyze 
 
AD Analog to Digital 
 
ADC Analog to Digital Converter 
 
IM Input Module (charge amplifier etc.) 
 
A, B, ... Channel 0, Channel 1, .... 
 
Channel one of eight strings built from input 

unit and ADC with memory 
 
Input input BNC connector, one IM can 
 have several inputs 
 
Record data from single channel within single 
 round (single shooting) 
 
Round one shot, which is stored on the disk 
 as single data file under the name 
 BADatNNN.dat (where NNN= 000 - 
 250) and it contains all eight records 
 from single channels 
 
Series more shots, which are stored in single 
 directory with user’s defined name of 
 series 
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4.2 TR 2519 Installation 

4.2.1 Safety Precautions for Working with TR 2519 Instrument 

 Only qualified personnel may work with TR 2519. 
Producer is not responsible for any accidents caused by 
unqualified personnel 

 If the TR 2519 or its equipment works improperly or if 
the instrument indicates any failure symptoms, do not 
use it! Replace the cable or power supply, send TR 
2519 for repairing to repair service! 

 The TR 2519 is assigned for DC power supply with 
nominal voltage 12V (or 24V DC for the relevant 
instrument modification, see the label on the rear 
panel).This voltage is not allowed to exceed the 
maximum value assigned in the chapter C2 Technical 
parameters of TR 2519. TR 2519 is permanently 
protected against incorrect voltage polarity, it is not 
protected against the overvoltage. It is necessary 
keeping safety precautions, which are assigned in 
standalone manual for this unit, if this one is used for 
current supply. Working personnel must keep valid 
safety precautions for handling with electro-technical 
devices 

 Cooling of internal electronic components is ensured by 
means of heat conducting through the case of the 
instrument. It is necessary to ensure free air circulation 
around this instrument. Do not place anything on the 
instrument case!!! 

 Respect working temperature range (see chapter C2 
Technical parameters of TR 2519 ) 

 Never connect higher voltage than nominal to the input 
connectors (see chapter C2 Technical parameters of TR 
2519) 

 In case of installation and TR 2519 operation keep the 
instructions for handling with ESD (Electrostatic 
Sensitive Devices). Protect it against static electricity, 
because the instrument contains sensitive integrated 
circuits. Never touch the connector pins and discharge 
yourself from static electricity before connecting/ 
disconnecting connectors 

 The instrument must be protected against the moisture, 
rain, temperature extremes (storage temperatures 
below –20 °C and above 40 °C) and temperature and 
mechanical shocks. The instrument is not allowed 
placing to direct sunlight, near thermal sources and 
heavy electromagnetic field sources, to the environment 
with aggressive chemicals, flammable and explosive 
vapors and gasses. Keep appropriate instructions 
against the fire 

 If the TR 2519 is moved to another environment with 
different temperature than 5°C, it is necessary to adapt 
the temperature difference sufficient time. Do not turn 
instrument on, if condensation is appears! 
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 Turn instrument off, if you will not make the 
measurement for the current day! Do not let the 
instrument turning on without checking, especially at 
night! 

 Disassembling or modification of the instrument is not 
allowed without previous permission of producer. If you 
violate these conditions, you lose the warranty. 
Producer is not responsible for any due accidents! 

 Use only original equipment and spare parts 
 The instrument can be used only for purpose, for which 

it was made. Producer is not responsible for any 
interpretation of measured results and for any accidents 
caused by their applications in practice. Producer is not 
responsible for any changes of instrument properties 
caused with usage or aging 

 The cleaning of TR 2519 is allowed only if the 
instrument is turned off and disconnected from power 
line. The instrument is allowed cleaning only with dry 
lint-free cloth. If the instrument is heavy dirty use damp 
lint-free cloth with few drops of mild detergent or use 
pure isopropanol. Never use alkalies, acids and organic 
solvents except pure isopropanol or ethanol! Especially 
it is dangerous using the solvents, which erode the 
polystyrene 

 Clean the connectors only with pure isopropanol and let 
them drying before measuring! 

 
 

 

Pay attention to maximum input voltage of all input 
modules – see reference manual/technical specifica-
tions. Exceeding of maximum values could destroy this 
instrument. 
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4.2.2 Installation of Transient Recorder 

 Before removing from transport cover the TR 2519 
must be acclimated by reason of the temperature 
equalization and minimizing the possibility of humidity 
condensation inside the instrument. After that it is 
possible removing the TR 2519 from the cover and 
placing it to a working place. Check, if the main switch 
on the rear panel is on the position 0 (off). If not, 
switch it to off 

 Install power supply for TR 2519 (see the proper 
manual) and connect it with original cable with the TR 
2519. Screw up optimize the nut of connector 

 Connect the TR 2519 (connector Cannon 9 pin) with 
network card (connector RJ45) by means of delivered 
nonstandard communication cable. Screw up the screws 
on the Cannon connector 

 Turn the TR 2519 on by means of the main switch 
which is located on the rear panel to position 1 (on). 
This will be indicated by means of green light POWER 
on the TR 2519 front panel in the section STATUS. 
After 5 minutes the other lights will be flash (READY, 
DATA), which indicates correct TR 2519 function. The 
instrument is ready for use 

 Connect outputs from relevant sensors to the BNC 
inputs. TR 2519 installation is finished. Now the 
installation of TR 2519 Control software for transient 
recorder control to the control computer is remained. 
See the next chapter 

 Turning TR 2519 off is possible by switching the main 
switch to the position 0 (off). If the TR 2519 will not be 
used for a longer time, disconnect it from the power 
line (see the proper manual for the power supply) 
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4.2.3 Installation of Control Software TR 2519 Control 

 The control computer have to fulfill minimal 
requirements assigned in the chapter “C6 Requirements 
for the control computer“ 

 Insert install CD into the CD drive of control computer, 
easy copy the folder with file BAControl.exe to disc C:\ 
and make shortcut to BAControl.exe 

 Check, if the TR 2519 is turned on and ready for 
measuring (see previous chapter) 

 Check properly installation of the network card 
hardware and drivers (see manual for computer or 
network card) 

 Now it is necessary to set up TCP/IP network 
communication protocol, which is very important for 
correct function of TR 2519 Control software. For 
Windows 7 environment it is step-by-step described in 
the pictures Fig. 2 and Fig. 3. In Fig. 4 it is setting of 
section Advanced (usually let default settings) 

 Then run TR 2519 Control software. Activate access to 
other parts of menu Calibration by means of password 
KIWAG in Calibration > Activate Calibration. Then in 
calibration menu choose part Calibration > Network 
and fill the table in accord with table - see Fig. 5 (set IP 
Address to 10.10.10.11, Port to 222) 

 Restart computer and try communication. Run program 
TR 2519 Control (shortcut or file BAControl.exe). The 
option File > New is enabled 

 For the correct communication turn on control 
computer first and after booting operating system (and 
after network card initiating) turn the TR 2519 on. If 
you have a problem, the trouble is probably in the 
network cards autoconfiguration and with plug and 
play technology, when the two computers are started 
at the same time. The communication could be 
corrupted, when some programs are started with the 
program TR 2519 Control at the same time (antivirus 
program or firewall) 
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Fig. 2: Network and sharing center  
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Fig. 3: Network connection 
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Fig. 4: Network settings 

 
 
 
 
 
 
 
 
  

Fig. 5: Network settings 
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4.2.4  Problems During the Installation and Their Solution 

 The green light POWER on the front panel does not 
light 

 Check power supply and cables. In case of the failure 
replace these parts. If TR 2519 still not works, contact 
maintenance service 

 The TR 2519 is turned on, the green light POWER  
lights, but after the five minutes the lights READY and 
DATA do not flash, the communication with the TR 
2519 could not be established try turn off the TR 2519 
and after one minute turn the TR 2519 on. If  the 
problem persists, contact maintenance service 

 The TR 2519 is turned on, the green light PWR ON  
lights and the light READY, DCOMP and DATA flash, 
but the communication with the TR 2519 could not be 
established 

 check network card configuration (see chapter B2.3 
Installation of control program TR 2519 Control) and 
restart control computer and TR 2519. (turn off and 
after one minute turn on control computer first and 
after booting operating system turn the TR 2519 on). 
Beware of the conflict with another network card or 
with some other programs (remove, disable 
problematical software/hardware). If the TR 2519 still 
not works, contact maintenance service 

 The communication is lost during measuring process 
(data transport from the TR 2519 to control computer 
“freeze“) the solution is as same as for point 3 

 The option File > New is inaccessible after starting TR 
2519 Control program or the whole panel of the virtual 
TR 2519 is not appeared (the panel is missing or panel 
of input modules are missing) after inserting name of 
the directory for data saving and after filling initial form 

 if some module misses, the firmware could not 
established connection with it. If the problem cannot be 
resolved according to point 3, the module is probably 
damaged and must be replaced, call service. If all 
modules are missing or the option File > New is 
inaccessible, the communication between TR 2519 and 
control computer was not established and the solution 
is as same as for point 3 
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4.3 Preparing TR 2519 for Measurement 

The whole philosophy about TR 2519 control will be now 
explained on the following typical ballistic example (from 
sensors connection to establishment and printing numerical 
results). If the user will try the measuring according this 
example, he will be able working independently. 

4.3.1 Typical Connection of Sensors to TR 2519 

The basic EPVAT & Accuracy measurement is in the 
following picture (Fig. 6): 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

Fig. 6: Connection scheme 

 
EPVAT & Target System Results 
 Graph and max value of chamber pressure 
 Graph and max value of port pressure 
 Graph and max value of muzzle pressure 
 Velocity (any combination of muzzle, two gates and 

target) 
 Action time 
 XY position of shot at target system 
 Target velocity and energy of bullet 
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4.3.2 Connecting Cables and Connectors 

The sensors are connected to TR 2519 by means of coaxial 
cables with BNC connectors. It is recommended to use only 
original cables from manufacturer for signal transfer from 
piezoelectric pressure sensors. Although this TR 2519 has 
circuits for compensation of cable leakage, it is necessary to 
keep all connectors clean and never touch the pins with the 
finger. The connectors should have only Fluoropolymer 
insulation and the cables high-quality dielectric with 
respect to used temperature range. 

4.3.3 Recommendations for Choosing and Using Single Channels (Inputs) 

The channels A – D CHARGE AMPLIFIERS have always 
single input and serve for piezoelectric pressure sensors 
connection. The channels E – H VOLTAGE INPUTS have 
either two inputs and they are used for common using for 
measuring of voltage signals in the range ±10 V. Signal of 
all two inputs of one channel is added and digitized by one 
ADC. These inputs are mostly used for connection of 
accelerometer or flash detector and for measuring of 
velocity and accuracy by means of optical gates. You can 
connect the gates with digital or analog output (displays 
the pass of bullet through the gate). You can use other 
sensors for example electromagnetic rings if meets voltage 
inputs range (the sum within the two inputs is max. ±10 V, 
in detail see technical parameters). These inputs can be 
used for connecting the other sensors, for example impact 
board (for signal recording during the shot impact on the 
target). 
There exists three groups of processes in dependence on 
time duration. The first group is relatively short (Internal 
Ballistics) – it is the time interval from the ignition to the 
time, when the bullet leaves the barrel. The second two 
groups are considerably longer – it records the flight 
(External Ballistics 1) and impact of the bullet on the target 
(External Ballistics 2). 
Transient Recorder always records all 400 000 points into 
internal high-speed memory. TR 2519 Control software 
allows adjust the interval of transferred data separately for 
the every pair of channels A+B, C+D, E+F, G+H and user 
can assign every channel into corresponding graph of 
Internal Ballistics, External Ballistics 1 or External Ballistics 2. 
The time intervals are fully independent to each other, 
overlapping is not necessary. This considerably improves 
speed of TR 2519 Control software and reduces a quantity 
of transferred data, because software transfers only data 
with true measured impulses. 
 

 

Pay attention to maximum input voltage of all input 
modules- see reference manual/technical specifica-
tions. Exceeding of maximum values could destroy this 
instrument. 
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4.3.4 What Data Will Be for Given Arrangement 

Standard TR 2519 is usually connected in the way that 
Chamber Pressure (Pc) signal starts the measurement (most 
reliable triggering). 
 
Optical gate for measuring of velocity V10 is placed in 
distance 10m from muzzle (distance 10m is between 
muzzle and center of optical gate base). Optical target 
system for measuring of velocity V25 and accuracy T25 is 
placed in distance 25m from muzzle (distance 25m is 
between muzzle and center of optical target base). 
 
This TR 2519 works on differently than other analyzers. It 
does not give any numerical readings directly, but it 
measures the real dependencies of all type of signals first. 
By means of the method, which is created in the program 
TR 2519 Control, it calculates from those dependencies 
needed numerical readings for any combinations of input 
signals. The following output data can be directly acquired 
for assigned TR 2519 connection: 
 waveform of chamber pressure Pc 
 waveform of port pressure Pp 
 waveform of accelerometer signal 
 waveforms of velocity gate signals (Start a Stop) 
 waveforms of target system signals (X a Y) 
 
By means of created method TR 2519 control calculates 
these numerical results: 
 value and time of maximum chamber pressure Pc 
 value and time of maximum port pressure Pp 
 velocity V10 
 velocity V25 
 coordinates and statistical evaluation of every shot T25 
 
It is acquired the review about velocity in dependence on 
the trajectory (it is possible to calculate drop of velocity and 
V0). Besides, it can be continuously checked the signal 
quality from all sensors and in case of some anomaly it is 
possible determining the cause of anomaly. If the 
numerical outputs are false, the round need not be 
repeated, but you can only modify the method. 
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4.3.5 Preparing TR 2519 for Measurement 

 Connect all cables from sensors with relevant TR 2519 
inputs (see previous chapters) 

 Check if TR 2519 is connected with control computer 
network card. If not, connect TR 2519 and control 
computer with this cable (9-pin Cannon – RJ45 
connector). Screw the Canon connector screws 

 Turn control computer on and wait while operating 
system is loaded 

 Turn TR 2519 on with the switch (rear panel).This will 
be indicated on the section STATUS DISPLAY by 
POWER light. After a max. 5 minutes the other lights 
will be flashing (READY, and DATA), which indicates 
correct function 

 Run program TR 2519 Control. It appears the main 
program window and if program is started for the first 
time, it is necessary to adjust its working directories. 
This is possible in Settings > Directories (Fig. 7) by 
assigning the whole path or by listing  existing 
directory. The content of single directories is following: 

 
- Data   - measured data  
- ASCII export  - data output in ASCII form 
- Settings (Methods) - TR 2519 setting (methods) 
- Reports   - measured results in the 

   protocol forms 
- XLS Reports  - measured results in the XLS 

  protocol forms 
- Calibrations  - calibration protocols 
- References  - reference curves 
- Report Forms  - C.I.P. forms 
- Sensors   - sensors for TR 2519 
- Data Backup  - directory for data backup 
- Temporary  - temporary files 
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Fig. 7: Directories settings 

 
 Check Settings > Colors, Preferences (Fig. 8 and 9). The 

reason of single items will be explained later, the setting 
should be according the picture. Grey (inactive) items 
has noeffect and their adjustment does not matter. 
Then it is necessary to assign channels A - H into 
relevant graphs by means of button according to 
picture Fig. 10 

 
Now the preparations for measuring are done. 
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 Fig. 8: Basic settings 
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Fig. 9: Basic settings 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Fig. 10: Graph organizer 
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4.4 Measuring Procedure, Method and Protocol Building 

If TR 2519 is ready (see previous chapter), it is possible to 
start measuring. It is recommended keeping the following 
method : 
 Entering of name of measured series and filling of form 
 Setting of main TR 2519 parameters 
 Shooting of first round 
 Building of data evaluation method 
 Shooting of the whole rounds of series 

 

4.4.1 Entering of Name of Measured Series and Filling of Form 

For each new series it is necessary to enter the name of 
series and also select directory for saving of data (if 
directory is different from default directory). In the main 
window of program TR 2519 Control select File > New or 
use the button   and type required name of series (or use 
Browse… for different directory).  
 
 
 
 
 
 
 
 

Fig. 11: Directory and name setting 

 
The single data files will be stored in the directory : 
C:\BA_Data\2009-12-02_5.56x45 NATO H823 – 003 
 
where: C:\BA_Data ... directory (see Settings > Directories) 
 2009-12-02_5.56x45 NATO H823 - 003 ... name of 

series (min. 4 characters!). 
 

 

Attention! 

MAXIMUM NUMBER OF SHOTS IS LIMITED TO 250. 

 
 
Browse... serves for changing of data storage directory. 
 
If you choose the name of existing series, after prompting 
and confirming with Yes  answer, the existing data will be 
replaced with the new data. 
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Fig. 12: Confirmation 

 
After the new name of series setting it appears the 
configurable form (Fig. 13 and 14). Its filling is not required 
and can be completed later (see standalone chapter for 
detailed description). After confirming Yes, the 
configuration file is loaded from the instrument and TR 
2519 virtual panel appears. 
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Fig. 13: Definition of report 
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Fig. 14: Definition of report 

4.4.2 Setting of Main TR 2519 Parameters 

Setting of all TR 2519 parameters and its measuring control 
is made by means of virtual TR 2519 panel. 
 

 

Fig. 15: Virtual panel 

 
Before first round it is necessary adjusting following TR 
2519 parameters: 
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Sampling rate (Sample Rate) determines the number of 
points of input signal (pressure etc.), which are recorded 
for every second. Its setting has effect for density of points 
on the final graph. Too high density made data processing 
slower and the large files are created on the disk. 
According to C.I.P. specifies the minimal sampling rate 
1MHz, which is usually used method in practice for 
pressure measuring of powder gases.  
 
Trigger level (Trigger Level) is the specific value. After 
exceeding this value the TR 2519 data recording is 
initiated. This value is pictured in percent of given range. 
For negative values has blue color, for positive values has 
red color and for zero value has green color. Set optimal 
trigger value for secure triggering without possibility of 
false triggering caused by noise and interference (and that 
is why the level 0.00% is not used during pressure 
triggering). Recommended value for typical measuring is 
12.5%. 
 
Trigger edge (Trigger Edge) determines, while data 
recording initialization will be followed after trigger level 
exceeding (Trigger Level) during signal increasing (RISE) or 
during signal decreasing (FALL). 
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This buttons serve for Transient Recorder setting (Settings) 
and make loading possible (LOAD) and saving (SAVE) on 
the control computer disk. Detailed description – see 
relevant text. 
 

Fig. 16: Saved data 

 
Virtual TR 2519 display provides important information 
about the setting and TR 2519 measuring procedure. There 
is the name of directory on the left topside in the first row 
(Name, Series), where the data will be stored, and the 
volume of total saved data in this series (Saved Data). 
There is the round counter on the right topside (Round), 
the number 0 means, that neither round was recorded so 
far. 

 
For understanding of function of other settings it is 
necessary explaining TR 2519 operation with the memory 
of AD converters. This memory is always filled with data in 
the range –100 000 to +300 000 points. The negative 
numbers are the so-called pre-trigger, i.e. the data which 
are recorded before recording initiation, zero is the time of 
triggering and positive numbers are data after recording 
initiation. For typical work are 400 000 points too many 
and that is why only required part of data are transferred 
to control computer. This part is set-up separately for every 
pair of channels A+B, C+D, E+F and G+H (see chapter B 
3.3 Recommendations for choosing and using single 
channels (inputs)) The beginning of memory reading is 
located on the left part of display, the end is on the right. 
The adjusted data are displayed for checking by bar graph 
form. The vertical red line indicates time of triggering 
(Trigger point). 
In the second line of display are written calculatíons of 
transported points and lengths of time intervals for every 
pair of channels (Record) and total volume of data for the 
one round. 
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Free horizontal line in the center of display is used for bar 
graph displaying with data transport process from TR 2519 
to control computer. 
 

 
    
 
 
 
 
 
 
 
  

There are the buttons for TR 2519 measuring control in the 
right part of virtual TR 2519 panel. Their functions are : 
delete last round (DELETE), run  measuring (RUN), stop 
measuring (STOP), automatic measuring of the whole 
series (AUTO) and testing of inputs (TEST). The button 
RUN has a second function READ (for reread of TR 2519 
data after modification of time intervals at first round of 
series) and the button STOP has a second function BREAK 
(interrupt of long measurement by using low sample rate). 
The function of those buttons will be described later during 
measuring. 
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Fig. 17: Scheme of recording 
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Fig. 19: Parameter setting 

 
The panel of input module – charge amplifier. 
A CH0 - the marking of channel, color is the same as color 
of curve in graph. 
Charge amplifier IM06-0-CHGA - the name of module. 
Four lines of free text - text field for placing description of 
relevant channel for better orientation of user (sensor type, 
its using, location on the weapon i.e.). 
Trigger - the switch for the trigger channel selection. 
Selected channel is highlighted with the red color. We 
recommend to choose the pressure channel as the 
triggering source, because by contrast to accelerometer it 
provides clear course with defined and almost constant 
shape and it is very resistive against the false triggering. 
Setting of calibration constant of sensor - button for setting 
of the pressure sensor calibration coefficient. For entering 
of sensor coefficient press this button and select item from 
menu : 
– Load is for loading of saved sensor parameters 
– Save is for saving of actual sensor parameters 
– Parameters serves for direct entering of sensor 
parameters in exponential form 
(button Inverted inverts the sensor polarity - for sensors 
with negative calibration coefficient let this button 
inactive). [pC/?] means user defined unit (different from 
previously defined). 
Range 2 600 pC, 5 200 pC, 10 600 pC, 20 200 pC - the 
selection of measuring range. Beside the title Range is 
displayed calculated value of measuring range in bar units 
(depends on the selection of measuring range and on the 
sensor calibration coefficient - provides information about 
true maximum pressure). 
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Filter 10 kHz, 20 kHz, 40 kHz, Off - the filter selection. 
Auto-zero on, Auto-zero off - the switch of automatic 
compensation of the offset and the cable leakage. 
Normally use only Auto-zero on, do not set this switch to 
Auto-zero off. This provides maximum measuring accuracy 
by changing of temperature and other ambient conditions. 
Only for measuring of pressure process which are longer 
than 100 ms it is necessary to disable this function (Auto-
zero off), because compensation causes distortion of 
measurement. 
Apply  - serves to send of actual settings into TR 2519. 

  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
The panel of input module - universal voltage input. 
E CH4 - the marking of channel, color is the same as color 
of curve in graph. 
Voltage input IM07-0-D2SA - the name of module. 
Four lines of free text - text field for placing description of 
relevant channel for better orientation of user (sensor type, 
its using, location on the weapon i.e.). 
Trigger - the switch for the trigger channel selection. 
Selected channel is highlighted with the red color. 
Range 1 V, 2 V, 5 V, 10 V - the selection of measuring 
range. Because this module has three summing inputs, the 
range means sum of three input voltages. 
Apply  - serves to send of actual settings into TR 2519. 
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4.4.3 Shooting of First Round 

If basic TR 2519 parameters are adjusted, it is possible 
running measuring. If the measuring is new, it usually does 
not contain the method for data evaluation. You have to 
shot first round and make setting of those data evaluation 
for the whole series. If the testing weapon is ready for first 
shoot, click on the button RUN, which is located to the 
right topside. The button AUTO is not allowed to be 
pressed. 
At first the control computer sends the information for 
setting of TR 2519 and then TR 2519 reads data for 
pretrigger (Fig. 20 and 21). After a several second it is 
displayed the information about waiting for trigger 
(Waiting for trigger, Fig. 22). The button RUN is now 
disabled, the measuring (waiting for trigger) can be 
aborted by enabled button STOP. 
 
 

Fig. 20: Run first round 

 

Fig. 21: Reading data for pretriggering 

  

Fig. 22: After pretriggering: stop 
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On the front panel of TR 2519 lights the red light READY. 
This indicates finish recording of pre-trigger and TR 2519 is 
ready for recording of round. When the light is on, you can 
shot the first round. Correct capturing of triggering is 
indicated by the lettering Trigger OK. 
 

 

Fig. 23: Shoot of first round 

 
The transport of data to the control computer is indicated 
by green light DATA. Data are sent separately for each pair 
of channels (see green bar graph). 
 

  

Fig. 24: Saving data 

 
Successful transport and graphs drawing are indicated with 
the round counter incrimination (Round) and with the 
counter of saving data volume (Saved Data). The button 
RUN is enabled at the same moment for next shot of series 
and DELETE for deleting of the last round of series. 
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Fig. 25: Saved round 

 
In this phase the data are stored on the control computer 
disk and it is possible to create the method for numerical 
evaluation of curves. It is necessary to create the method 
after the first round of series, because creating or 
modifying of method is disabled from the second round 
and it is possible to edit some parameters only. The 
method can be changed after finishing of measurement. 
 
Description of functions is simplified and special functions 
(correction of time interval with rereading of data, 
interrupting of measurement with low sampling frequency 
etc.) are described in reference part of TR 2519 manual. 
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4.4.4 Building of Data Evaluation Method  

 
Display of control computer now includes virtual TR 2519 
panel and main program TR 2519 Control window. 

 
  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Fig. 26: Measuring graph 

 
While TR 2519 virtual panel controls the instrument during 
measuring, the main window of TR 2519 Control program 
integrates all functions of program (measuring, data 
displaying and processing) to single complex. Creation of 
method for data evaluation is also performed in this 
window. 
It is necessary to know several actions for successful 
creation of method - setting of graph (axis and colors), 
displaying and hiding of curves, switching of graphs and 
zoom function (Zoom). These functions are called from the 
main window of TR 2519 Control program. 
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Setting of graph scales is accessible in Preferences > Scales 
and contains setting of scales of all Y­axes (Fig. 27). The 
option Auto sizes axes according to founded curves 
minimum and maximum. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Fig. 27: Settings of graph scales 

If you want to choose fixed axis scale, uncheck option 
Auto and type choosen value of curves minimum and 
maximum. The possible result is displayed on the Fig. 28. 
Automatic scaling of axes can be temporarily enabled by 

means of button   . 
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Fig. 28: Graphs A – D/E – F/G – H 
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Other possible settings are on the picture Fig. 29, 30 and 
31 (during measurement are accessible only some options - 
for detailed description see TR 2519 reference manual). 
 
 

 
 
  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

      Fig. 29:  Graph settings 

 

Fig. 30:  Graph settings 
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Fig. 31: Graph settings 

 
 
Displaying and hiding of curves 

 
 

     
 

 by means of buttons with the symbol of eye, which are 
located at the left topside margin of main program 
window (beside the graph). 

 

 If eye button has highlighted color, 
the curve is displayed. If you press this button, the color 
has to be dull and the curve is hidden. When you click on 
the button again, the curve will be displayed. 
 
Graph switching is possible by means of switch in tools 
panel of main program window : 
 

  graph of Internal Ballistics 
 

  graph of External Ballistics 1 
 

  graph of External Ballistics 2 
 

  graph of Internal Ballistics - Statistics (inaccessible 
during measuring) 
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Zoom is the next function of program. Selection of the 
curve, which is displayed in separate window Zoom, is 
made by means of zoom switches beside the buttons for 
curve displaying and hiding. The function Zoom is allowed 

only for displayed curves , it is prohibited for 
hidden curves. Active function Zoom is indicated with 

change (activating) of zoom button in tools panel , 
after its deactivating the function Zoom is deactivated. 
After Zoom activating it is opened in a separate window 
(Fig. 32) with the  selected part of the curve. This part of 
selected curve is terminated with horizontal and vertical 
cursors and highlighted with color in the main program 
window (color setting see Settings > Preferences > Graph 
colours > Selected area). It is possible to drag&drop the 
cursors by means of mouse and changing magnification of 
relevant part of curve in the window Zoom. 

The buttons    serves for locking and unlocking of 
relative cursor position for easy examination of curve 
details (it is possible moving with the pair of locked cursors 
at the same time). 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Fig. 32: Zoom function 
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Creation of method for data evaluation is activated and 

deactivated by means of button  Computing, which is 
located at the panel of tools of main program window. 
Make all required curve displayed on all graphs by means 
of previously described functions and adjust their imaging 
according to your requirements. Then press the button of 
function Computing. It appears empty window for creation 
of method for data evaluation. It contains group of control 
buttons  (Fig. 33). If the window is not empty it is possible 

to delete all lines by means of button   Delete 
all. 

Fig. 33: Creation of method 
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The first line of method will be maximum pressure 
determination on the A curve (red). Press the button   Add 
pressure, which serve for addition of single line with 
calculation of pressure maximum and relevant data times. 
 

 

Fig. 34: Definition of method 

 
Meaning of single line items : 
 
Row: line number. Checkbox determines addition of results 
to reports. 
Type: icon for identification of function of line (Pmax) 
Start / Interval: up - button for setting of beginning of 
Pmax time admeasurement 
down - button for setting of interval for calculation of 
Pmax 
Edge: setting of evaluation from rise or fall edge of impulse 
Min. width: setting of minimal accepted width of impulse 
Description: naming of this line (any text) 
Results: time to Pmax and value of Pmax 
Extended values and results: calculation of time to 
adjusted pressure level (%Pmax) 
Limits (Max/Min): settings of limit values of Max(Pmax) 
and Min(Pmax) 
C.I.P. coeff.: calculation of C.I.P.correction (setting of 
correction coefficient) 
NATO coeff.: calculation of NATO correction (setting of 
value for correction of result) 
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Press button Start OK and for transition to edit 
mode press the button   Edit. This open the window Zoom, 
where it is displayed highlighted area of selected curve, 
which is limited with vertical cursors. The button on the 
number and its color is corresponding of color of selected 
curve. Choose required curve by means of button with 

symbol of magnifying glass . Because the 
beginning of time admeasurement for maximum pressure 
is given with accelerometer, choose the curve C. Then 
choose by means of vertical cursors required area and by 
means of single horizontal cursor, which represents 
threshold level, set its point of intersection with the curve. 
This cursor is drawndrawn also in the window Zoom and 
founded point is highlighted. The relevant computed value 
of time is inserted to the window Computing. For accept of 

this setting press the button  Apply to all - edit mode 
is cancelled and setting is stored. If edit mode is leaved 
with other way, the setting ís ignored! For cancel of edit 

mode without saving press the button  Escape . 
Next choose appropriate edge of impulse (Edge) and press 

the button  . Similar is setting of minimal width of 
impulse (Min. width). 
 
 
 
 
 
 
 
 
 
 
 
 
 

Fig. 35: Window zoom 
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The next point in sequence is setting of interval for 
calculation of maximum pressure Pmax. Press the button 
Interval OK to choose setting of this interval and by 

pressing button   Edit go to edit mode. At first 
select appropriate curve of channel A by pressing button 

with symbol of magnifying glass   and select the 
area for searching of maximum pressure with vertical 
cursors  Horizontal cursor is not presented here. Founded 
maximum is highlighted at the window Zoom. Into the 
area Results are written time of maximum Pmax from 
beginning (here impulse of accelerometer) and value of 
maximum pressure Pmax. 

For accept of this setting press the button   Apply 
to all (edit mode is cancelled and setting is stored). 
 
Next select length of filter for noise suppression by 
searching of maximum value of pressure in column Min. 
width (maximum value is calculated as average value of 
preset area - default value is 1, zero means Filter Off). For 

accept of this setting press the button   Apply to all. 
 

 

Fig. 36: Calculation of maximum pressure 
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Type any text to the field for naming of line, which 
characters measured quantities and will serve for their 

identification (Fig. 37). Accept with the button  
Apply to all . 
 
The next point is calculation of the time, which is needed 
for reach of adjusted level of pressure (in percent of found 
maximum pressure). For activation of this function check 
the box and adjust required pressure level. In results area 
appears calculated time. For accept of this setting press the 

button  Apply to all. The work with C.I.P. / NATO 
corrections is activated and filled with the same way as the 
previous items. 
 
 

 
 
 
 
 
 
 
 
 
 

 

Fig. 37: Calculation of time 

 
The first line building for pressure curve evaluation is 
finished. 
If you want to edit setting, choose it the appropriate item, 
then by means of Edit go to edit mode, correct cursors 
setting and for finishing of edit mode use button Apply to 
all for saving of changes or Escape for keeping of previous 
setting. For editing of other setting the edit mode is not 
needed, but after inserting of new value use always the 
button Apply to all or Escape. 
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Analogical to the first line is filled the second line for the 
curve B (blue). 
 
Third line of method will be contain assignment of time 
interval, the so-called Action time. Press button 

 Add time/velocity, which serves for addition of 
single line with calculation of time interval and after set of 
base size also for calculation of velocity. 
 
 
 
 
 
 
 
 
 

 
 

 
 
 
 

 

Fig. 38: Calculation methods 

Meaning of single line items : 
Row: line number. Checkbox determines addition of results 
to reports. 
Type: icon for identification of function of line 
Start/Stop: up - button for setting of time admeasurement 
start 
down - button for setting of time admeasurement stop 
%: button for selection of horizontal cursor mode (absolute 
position in units according to axe or relative position in 
percent of maximum value in selected interval) 
Edge: setting of evaluation from rise or fall edge of impulse 
Min. width: setting of minimal accepted width of impulse 
Description: naming of this line (any text) 
Results: calculated time interval 
Extended values and results: option for calculation of 
velocity by entering: 
 up - distance of first gate of given pair from muzzle  
 down - size of base for measuring of velocity (distance 

between pair of gates) 
Limits (Max/Min): settings of limit values of Max(time, 
velocity) and Min(time, velocity) 
C.I.P. coeff.: calculation of C.I.P.correction (setting 
of correction coefficient) 
NATO coeff.: calculation of NATO correction (setting 
of value for correction of result) 
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Press button Start OK and for going to edit mode also the 

button  Edit. At first choose required curve of 
channel A by pressing button with symbol of magnifying 

glass . Because the beginning of time 
admeasurement for Action time is given with 
accelerometer, select curve C. Then select required area by 
means of vertical cursors and by means of single horizontal 
cursor, which represents threshold level, adjust its point of 
intersection with the curve. This cursor is drawn also at the 
window Zoom and founded point is highlighted. The 
relevant calculated value of time is inserted to the window 
Computing. For accept of this setting press the button 

 Apply to all - edit mode is cancelled and setting is 
stored. If edit mode is leaved with other way, the setting is 
ignored! For cancel of edit mode without saving press the 

button  Escape . 
Next choose appropriate edge of impulse (Edge) and press 

the button . Similar is setting of minimal width of 
impulse (Min. width). 

 
 
 
 
 
 
 
 
 
 
 
 

Fig. 39: Action time 
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Continue with setting end of time of the measurement. 
The setting process is as analogical as at previous point. 
After setting of begin and end of time interval is written 
the result – calculated time interval. 
The next point is filling of naming of this this line. After 
finishing this procedure it is necessary to use the button 
Apply to all. 
Then it is possible to continue in calculation of velocity 
from measured time interval (this function is not used 
here). For activation of this function check the box and 
adjust required distance of first gate of relevant pair from 
the muzzle and the size of measuring base. In results area 
appears calculated velocity. For acceptance of this setting it 
is necessary to use button Apply to all. 
Similarly it is possible to enter limits and C.I.P. / NATO 
corrections. 
Final building of first three lines you can see at the Fig. 40. 

 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 Fig 77: 
 

 
 
 
 
 
 
 

Fig. 40: Time interval 

Building of the next lines at the window Computing is 
analogical to the procedure, which has been explained for 
the first three lines. Small change is only in fact, that this is 
measuring of velocity and that is why this function is 
always activated together with set of relevant entries.  
The following pictures show also the signals from optical 
gates. Pay attention to setting of relevant intervals for 
single gates - it is accepted always only the first exceeding 
of horizontal cursor in adjusted interval in selected 
direction: first rise edge from right or left side or first fall 
edge from right or left side. 
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Line No. 4 – velocity measurement (optical gates – first 
gate start, second gate stop). 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Fig. 41: Velocity measurement 

 
 
 
 
 
 
 
 
 
 
 Fig 83: 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Fig. 42: Velocity measurement 
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Line No.5 – measurement of accuracy and velocity by 
means of electronic target system. Detailed description is in 
separate chapter. 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Fig. 43: Accuracy and velocity 

 
 
 
 
 
 
 
 
 
 
 
 
 
 Fig 89: 
 
 
 
 
 
 
 
 
 
 
 

Fig. 44: Accuracy and velocity 
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Summary of functions at the window Computing : 
 

 - (1) Add Time/Velocity - calculation of time 
and velocity 

 - (1) Add t/v integral - calculation of time and 
velocity by means of integral (it requires special 
analog gates) 

 - (1) Add t/v zero - calculation of velocity from 
zero crossing (derivative sensors, as a AC light 
gates and electromagnetic rings) 

 - (1) Add pressure - calculation of the 
maximum pressure 

 - (1) Add Y=f(X) - computing of function value 
for predefined value of X (time) 

 - (1) Add adv. Y=f(X) - computing of function 
value at start impulse 

 - (1) Add Average - computing of average Y 
value in selected X interval (time) 

 - (1) Add integral - calculation of integral 
(between cursors) 

 - (1) Add adv. integral - calculation of integral 
(between start/stop impulse) 

 - (1) Add gradient - calculation of rate of rise 
(rate of fall) of the curve 

 - (1) Add Rise/Fall - computing of parameters 
of impulse edge 

 - (1) Add Mask - mask for checking of shape of 
curve 

 - (1) Add Rate Of Fire - calculation of Rate of 
Fire 

  - (1) Add target - calculation of target 

 - (1) Add user - input of any numeric value 

 - (1) Add Start-Stop Counter - computing of 
time/velocity by means of counters 
(BA04SE only) 

  - (1) Add GPS - reading of GPS (UTC Time and 
Coordinates) (GPS Garmin, special accessory) 

 - (1) Add Calculation - computing between 
result of rows 
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  - (1) Delete row - delete selected row 
 

  - (1) Delete all - delete all rows 
 

  - (A) Edit - switching of selected row to 
edit mode 

 

  - (1) Apply to all - exit from edit mode 
and saving changes (for all round of 
series) 

 

  - (A-1) Apply - exit from edit mode 
and saving changes only for current 
round 

 

  - (A) Escape - exit without saving 
 

 

  - (1) Up, Down - selected line feed 
up/down 

 
 
(1)  =  accessible only for the round No.1 of 

relevant series 
 
(A-1) =  accessible for all round of relevant 

series except the round No.1 
 

(A)            =  accessible for all round of relevant  
series 
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Important advices for building method for data 
evaluation: 
 During searching of maximum pressure is always 

founded the point with maximum value in the interval 
selected with cursors. In the neighborhood of this point 
(adjusted, default ±5 points) is determined medium 
value, which represents founded maximum. This 
filtration is necessary for noise elimination 

 Program approximates measured curve with line in 
vicinity of intersection with horizontal cursor (which 
represents threshold level) 

 It is convenient to place threshold level with respect to 
maximum interference elimination (see Fig. 42 … 47) 

 It is possible to filtrate off undesired interference and 
fault impulses by setting of time interval for searching 
of threshold level intersection with the curve, by 
moving of threshold level cursor, by setting of rise/fall 
edge and by setting of minimal acceptable width of 
impulse. This operation is not possible to make at 
conventional BA and causes false results. By contrast to 
common threshold setting with trial-and-error method, 
here it is provided lucid and easy setting in GUI 
(Graphic User Interface). It is possible to determine all 
signal anomalous and effectively to intervene - see next 
pictures: 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Fig. 45: Determination of signal anomalous 
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Fig. 46: Determination of signal anomalous 

 
 
 
  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Fig. 47: Determination of signal anomalous 
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4.4.5 Shooting of the Whole Rounds of Series 

After assembling of data evaluating method it is possible to 
continue in measurement of next rounds of relevant series. 
There are two options, which can be arbitrarily combined 
during measuring process: 
 Manual mode (switch AUTO is not pressed) - before 

every round it is necessary by pressing of button RUN 
adjust TR 2519 to mode of waiting for trigger impulse. 
This waiting for trigger impulse is indicated by lettering 
Waiting for trigger (see Fig. 22) and by lighting of red 
light READY on front panel of TR 2519. Then it is 
possible to shot one round 

 Automatic mode (switch AUTO is pressed) - before first 
round it is necessary by pressing of button RUN adjust 
TR 2519 to mode of waiting for trigger impulse. This 
waiting for trigger impulse is indicated by lettering 
Waiting for trigger (see Fig. 22) and by lighting of red 
(older versions orange) light READY on front panel of 
TR 2519. Then it is possible to shot one round. Always 
if the reading of data is finished, the TR 2519 is 
automatically set after every round to mode of waiting 
for trigger impulse and it is possible to shot next round 

 
Measurement (waiting for trigger impulse) can be aborted 
by button STOP. 
Last round can be deleted by means of button DELETE, if 
button is accessible. 
Numerical results can be watched during measurement. 
This is possible at opened window Computing, where the 
values are updated after each round including the window 
Zoom (if window is opened by means of button for setting 
of some limit - see Fig. 34 and 38). 
The next option is watching of report of measured series 

 (File > Report measured series), which provides 
summary information about all rounds of relevant series 
including statistic calculations. 

Last option is the report of current round  (File > 
Report actual round), which contains key results about 
pictured round. 
After shooting of the whole round series it is necessary to 
abort mode waiting for trigger impulse by means of button 
STOP (if button is activated) and closing TR 2519 panel 

means of button  in right topside corner. Measured 
data will be automatically stored at this moment (data are 
stored to temporary directory during measuring process 
and will be copied to predefined data directory after 
closing of TR 2519 panel) and selected output reports are 
exported. 
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4.5 Work with Measured Data 

4.5.1 Group Organizer, Displaying and Printing of Results 

Program allows dividing of data up to ten groups for 
interlaced shooting or for comparison of groups of 
ammunition. Each group is separately statistically processed 
and the results are again processed to overall report. 
Dividing is allowed by the function Group Organizer, 

accessible by button : 
 

Fig. 48: Group organizer 

 
In the left column are numbers of rounds and up are 
names of groups (any text, it will be appeared in title of 
report). On the top are buttons for quick dividing of 
rounds to groups: 
All in 1 (all to first group) 
No. of GRP: 2 (one half to 1st group and one half to 2nd 
group) 
No. of GRP: 3 (first third to 1st group … third third to 3rd 
group) 
etc. 
No. of ALT: 2 (alternate to 1st and 2nd group) 
No. of ALT: 3 (alternate to 1st, 2nd and 3rd group) 
etc. 
 
It is possible to modify allocation by means of array of 
buttons. After closing the window it is automatically 
performed data recalculation according to actual allocation. 
Checkbox Report determines group, which is put into 
reports and statistic calculations (unchecked groups are 
hidden in all reports). 
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The results of measurement are: 
 
a) four graphs 1. Internal Ballistics 
 2. External Ballistics 1 
 3. External Ballistics 2 
 4. Internal Ballistics - Statistics 
 
b) computed values 1. Target System 1 
 2. Target System 2 
 3. Reports (pictured and saved on 

    the disc) 
 
The work with the first three graphs has been described 
during the measuring process. 
Fourth graph Internal Ballistics - Statistics is not accessible 
during measurement and contains the data from channels 
which were placed into graph Internal Ballistics. Software 
calculates average (AVG), minimum (MIN) and maximum 
(MAX) curve (“minimum“ and “maximum“ curve are 
envelope curves of all rounds, “average“ curve is mean 
value of all rounds). Their displaying or hiding is possible by 

means of button   . It is also possible to 

show all rounds by means of button . The reference 

curve can be pictured by means of the button , if 
this one is loaded. It is possible to choose graph of specific 

group by means of the buttons  - . If 
only single group is chosen (pictured), it is possible to save 
its curve AVG as reference (File > Save ref...) for visual 
comparison with other measured curves. The other 
functions are the same as in previous both graphs. It is 
possible to show report for this statistic graph (File > 

Report statistics) by means of the button . 
For each graph exists the list of relevant numerical results 
according to setting of data evaluation method at the 

window Computing. The report of current round  
(File > Report actual round) is determined for first three 

graphs and report of statistics  (File > Report statistics) 
for the fourth graph. 

Report of measured series  (File > 
Report measured series) contains summary information 
about all rounds of relevant series including statistic 
calculations. The data are allocated to the groups, each 
includes basic statistic calculations (arithmetic average 
(Avg), standard deviation (SD), maximal and minimal value 
(Max, Min) and dispersion (Delta)). The summary statistic 
including corrections of CIP coefficient is placed in the end 
of report. 
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Preselected reports in Settings > Preferences > Misc) (are 
always stored after finishing of measurement or by data 
saving on the disc to preset directory - Settings > 
Directories (Fig. 7). These reports can be easy printed or 
processed in programs as a MS Word etc. 

Final Report  (File > Final Report…) serves for 
comfortable direct printing of results (see Reference 
Manual). 
Each graph can be transferred to another program through 

the Clipboard (by means of , Edit > Copy or Ctrl+C), 
printing of graph is possible by File > Print or Ctrl+P. 
 

4.5.2 Selection of Single Round and Delete of Selected Round 

It is possible to list between the rounds by means of 

buttons  or Select > First, Previous, 
Next, Last). Their function is (from the left) : first round, 
previous round, direct selection, following round and last 
round. Selected round can be deleted by means of button 

 or Edit > Delete. For permanent delete it is necessary 

to save data on the disc by means of the button  or 
File > Save, because the program by reason of original data 
protection works only with their copy. 

 
  

n

x
xAvg

n

i
i∑

=== 1
( )

1
1

2

−

−
=
∑
=

n

xx
SD

n

i
i

MinMaxDelta −=)(
1

i

n

i
xMin Min

=

=)(
1

i

n

i
xMax Max

=

=



User Manual 

2519A_002-606e-10.12  Page 63 

 

4.5.3 Modification of Measured Data Evaluation 

It is necessary to remind basic rules: 
 it is possible changing method setting of data 

evaluation by means of Computing, i.e. addition and 
erasing line, text and numerical values changing only 
during first round of relevant series and this fact has 
effect for all round of relevant series 

 for second and next rounds it is possible to modify only 
cursors setting (intervals and thresholds), it is not 
possible to add or delete line, change the text and 
numerical values. The changes in setting have influence 
only for this round 

 
 
It follows two consequences: 
 if it is necessary to change the whole method setting, 

choose round number one and make required 
modifications as during measurement 

 if you find out, that some numerical value for other 
than first round in report is not quite correct, choose it 
and in Computing try to determinate the cause of fault 
evaluation from the graphs and try to get correct result 
with cursors moving. This change of setting has not 
effect for other round series 

 
If the changes may have permanent character, it is 
necessary to save data on the disc by means of button 

 or File > Save, because the program by reason of 
original data protection works only with their copy. 
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4.5.4 Filtering of Data (Built-in Running Average Filter) 

These filters serve to suppression of noise. It is possible to 
use this filter immediately during measurement or late after 
measurement. Original data is always retained and data is 
automatically restored after switch-off filter. 

Filter is activated by use of button  or in menu Graphs 
and computing > Filters. It appears the window (Fig. 49), 
which contains setting of running average filter for each 
channel: 
- checkbox of filter activation 
- setting of filter parameters (number of points for 
computing of average value - higher number increases 
efficacy of filtering, but increases distortion of curve). 
Maximum number of points for computing of average 
value is limited to 1% of all measured points of relevant 
curve. 
Channels filtered during measurement are color marked. 
 

 
 
 
 
 
 
 
 
 
 
 
 
 

Fig. 49: Filter settings 

 

Fig. 50: Virtual panel 
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4.5.5 Aborting of Shooting and Finishing of Shooting of Other Rounds of the Loaded 
Data 

Program allows breaking of shooting and finishing of 
shooting of remained rounds later. The condition is the 
necessity to use the same method for data evaluation (this 
is automatically provided). Let’s suppose that data are 
stored on the disc. They can be loaded by means of button 

 or File > Open and activate measuring mode by 
means of Measurement > TR 2519. It is opened TR 2519 
panel, which is set according to used method. It is possible 
to continue with measuring with typical way. When you 
finish the shot, it necessary to break waiting for trigger 
impulse by means of button STOP, if button is activated, 

and close TR 2519 panel by means of button  in right 
topside corner. It appears the window for data saving with 
predefined name of current series. You can overwrite 
previous data with new data (= previous+ new) or save 
these data under different name. If you choose Cancel, 
previous data will be kept without change and new data 
will be stored on the disc only in temporary copy. If you 
terminate program or you start new measurement (File > 

New or you use the button  ), the new data will be 
lost. Do not forget to save the data on the disc by means 

of button  or File > Save. 
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4.5.6 Function READ and BREAK 

Function READ is accessible only for first round of series. 
Function READ is accessible after changing of time 
intervals for reading of data of first round (it substitutes 
the button RUN in right part of virtual TR 2519 panel). 
Memory of AD converters is always filled with data in the 
range –100 000 to +300 000 points. The negative numbers 
are the so-called pre-trigger, i.e. the data which are 
recorded before recording initiation, zero is the time of 
triggering and positive numbers are data after recording 
initiation. For typical work are 400 000 points too many 
and that is why only required part of data are transferred 
to control computer. This required part of data you have to 
set-up separately for every pair of channels A+B, C+D, E+F 
and G+H before first round by means of your experiences. 
After shooting of first round of series you can find out, that 
your guess of required data was incorrect, because 
required signal is not present (signal is out of time window) 
or amount of data is too big (time for transfer of data from 
TR 2519 to control computer is very long). Usually you 
have to delete this round, to correct of time intervals and 
to shot next "first" round etc. This TR 2519 presents new 
method for solving of this problem. You have to correct 
only the time intervals for reading of data and to reread 
the same data by using of command READ without 
shooting of new "first" round. It is possible to repeat this 
action until the settings is acceptable. Then you can 
continue with shooting of next rounds, but without 
possibility of other corrections of time intervals. 
 
Function BREAK serves for necessary manual breaking of 
measurement and reading of data from TR 2519 for 
sample rates 50 kHz and less (it substitutes the button 
STOP). 
After triggering the TR 2519 measures input signals and 
stores data on internal memory. Because the memory is 
very deep (300 000 points) and TR 2519 fills always all the 
memory, by using of sample rate 100 Hz you have to wait 
3000s for next measurement! TR 2519 solves this problem 
by use of function BREAK. After exceeding the longest 
time interval for reading of data this function could be used 
for breaking of measurement and for reading of data. This 
time is also maximum value for correction of time intervals 
by means of function READ. 
Function BREAK is accessible only for sampling frequency 
50 kHz and less, because filling of all RAM by 100 kHz 
takes only 4s (1 MHz – 0,4 s). 
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Ballistic Test Barrel
Universal Bal. Breech UZ-2002
Device Rest STZA 12

EPVAT & Target System
Results :
- Graph and maximum value of chamber pressure
- Graph and maximum value of port pressure
- Graph and maximum value of muzzle pressure
- Velocity (each combination of muzzle, two optical gates and target)
- Action time (and generally all time intervals)
- XY position of shot at target system
- Target velocity and energy of bullet

Target System
WTS03

Light Screen
WLS03

Piezo
Accelerometer

Piezo
Kistler
6215

Piezo
Kistler
6215 Piezo

Muzzle Sensor

START

STOP

OUT X

OUT Y

4.6 Working with Electronic Target WTS03 

4.6.1 Connecting Target to TR 2519 

The program allows connection up to two electronic 
targets WTS03 to single Transient Recorder TR 2519. 
Recommended connection to TR 2519: 

 
  



 162BUsers Guide Transient Recorder 163BType 2519A… 

Page 68  2519A_002-606e-10.12 

4.6.2 How to Measure and Target Data Evaluation 

The knowledge of basic measurements on TR 2519 are 
supposed and that is why only some specific properties will 
be explained in details. Everything will be described on the 
example of EPVAT measurement with single target system. 
At first set required method of data evaluation in Settings > 
Preferences > Misc (Statistical or Graphical). Setting can be 
changed also for measured data and than all values are 
recalculated. 

Run measurement File > New or use the button , type 
required name of series and fill out CIP blank form (if you 
will use graphical method of target evaluation, do not 
forget enter the bullet diameter). The panel of virtual 
instrument appears. Set it according to following picture: 
 

 

Fig. 51: Virtual panel 

 
Optical gates of target have response time for about 1­2 µs 
and sample rate 1 MHz is usually sufficient. Using rate 
higher than 5 MHz usually does not provide better 
accuracy of measurement. We strongly do not recommend 
to use lower value than 1 MHz !!! The other adjustment 
(input voltage range, trigger level etc.) should be chosen 
according to concrete conditions (ammunition type, 
distance and interference). The setting from the picture can 
be thought as default for most measurement, but 
serviceman should recommend concrete suitable setting 
during installation of target at customer. 
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If TR 2519 setting is done, the first round of series can be 
shot. This is example of record from channel G and H: 
 

Fig. 52: Graph of target system 

 
Target system converts coordinates by means of oblique 
gates to time interval. The first pair of overlapping impulses 
are given by pass of bullet through first normal gate, the 
last pair of overlapping impulses are given by second 
normal gate. These gates form the pair at once for 
measuring of velocity on the base 0.6 m. The middle two 
impulses are created by pass of bullet through oblique gate 
X (brown color, G) and Y (green color, H) and their 
position against the impulses from the normal gates 
contains information about the position of bullet. The 
method for evaluation of position X and Y is built on this 
process. Open the window for computing by means of the 

button  Computing, which is in the panel of tools in 
main program window. 
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Fig. 53: Data analysis of target system 

 

The cursors can be adjusted as usually (see previous 

chapters) by means of buttons  Edit, 

 Apply to all and  Escape. The difference is 
in the fact, that there are four vertical cursors instead of 
two common cursors. Cursor 1 and 2 determinates the 
interval for impulse searching from the first orthogonal 
gate , cursor 2 and 3 determinates the interval for impulse 
searching from the oblique gate X (or Y) and cursor 3 and 
4 is for impulse searching from the second orthogonal 
gate. Set threshold level so as reading of point from the 
curve has been reliable and interference has been minimal. 
We recommend to work with falling edge of impulse (the 
impulse has higher edge slope and reading will be more 
accurate). Setting of minimum acceptable impulse length 
you can reach better interference rejection (shock waves 
etc.). 
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The whole building of method is viewed from previous 
picture for calculation of X axis and from following picture 
for calculation of Y axis : 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 

Fig. 54: Building method 

 
 
The next rounds are shot with common way (see chapter 
B 4.5 Shooting of remained rounds of relevant series). 

 
It is possible to watch also picture of target 1 and 2 in 
shooting process. 
 
It can be activated/deactivated by pressing the button 

 . 
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Fig. 55: Graph of target 

 
Selected method for target evaluation is pictured in the 
bracket of upper left bar. Active hit is highlighted by red 
color and its measured course is also pictured in main 
program window. It is possible to make switching active hit 
by means of the selection of pictured round in main 
program window. You have to click on the relevant hit. 
The coordinates of active hit are pictured upper right. 
 
It is possible to switch representation of relevant group by 
means of the buttons if the round are allocated to the 

groups by means of the function Group Organizer  
after measurement process - see Fig. 56. 
 
The set of buttons (to the right) serves for switching on/off 
the relevant calculations, which are pictured on the target 
and for listing of numeric values. The last button Distance 
can admeasure distance between active point and next any 
point. 
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The function Zoom can be activated with mouse left click, 
by cursor moving (drag & drop, it appears zoom rectangle) 
and button release. The other option is in the picture 
Fig. 57. The function is activated by clicking on the left or 
bottom border of target. It is possible to set numerically the 
scale of axes or choose the function Auto Scale (button 
Auto). 
 
Button Coefficients serves for calibration of target system 
(see WTS03 User's Guide). 

 
Button Fixed serves for setting of target scale to predefined 
values (see setting of axes in menu Settings), button Auto 
sets Auto Scale of X and Y axe. 
 
It is possible to transfer picture of target through clipboard 

(by means of , Edit > Copy or Ctrl+C) to any 
Windows application - all rounds on the target are 
enumerated. 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Fig. 56: Selection of group  
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Fig. 57: Distance evaluation 

 
 
If some rounds cannot be evaluated (for example by 
reason of signal exceeding from the limitations, which are 
set in the calculations), their numbers appear in the list 
below the target. The list of not evaluated rounds can be 
displayed or hidden by means of the bar 

, see 
Fig. 58. If the round from this list is chosen, relevant course 
of signal is displayed in main program window and it is 
possible to make correction of evaluation by means of the 

button  Computing. The round is then automatically 
aligned to the target. 
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Fig. 58: Distance evaluation 

 
The result of measurement is picture of target (see above) 
and report, which is accessible by means of the button 

.  
 
If the rounds are allocated to the groups, they are also 
allocated in report. Each part has partial statistic and 
Overall statistic is released in the end. The meaning of 
single items (results) will be explained on the following 
sample of report. The report is not complete, but only the 
end part (partial statistics are quite analogical). 
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Overall statistic 

================================================================================================== 

       | 1 (Target)       | 2 (Velocity UP) | 3 (Velocity ->) | 4 (Velocity <-) | 5 (Velocity DN)  

 Round |  X [mm]   Y [mm] |  Speed [m/s]    |  Speed [m/s]    |  Speed [m/s]    |  Speed [m/s]     

-------------------------------------------------------------------------------------------------- 

  Avg  |    - 58     - 38 |      685.2      |      684.1      |      687.6      |      685.7       

  SD   |       4       24 |        3.4      |        3.0      |        3.0      |        3.2       

  Max  |    - 53      - 8 |      687.9      |      686.6      |      690.0      |      688.3       

  Min  |    - 63     - 67 |      680.7      |      680.1      |      683.7      |      681.4       

 Delta |      10       59 |        7.3      |        6.5      |        6.3      |        6.9       

 Wk[J] |                  | 0.000E+00       | 0.000E+00       | 0.000E+00       | 0.000E+00        

-------------------------------------------------------------------------------------------------- 

 CIP K |       2        2 |        2.0      |        2.0      |        2.0      |        2.0       

  

 Avg + |    - 50       10 |      691.9      |      690.1      |      693.6      |      692.2       

 Avg - |    - 66     - 86 |      678.4      |      678.1      |      681.6      |      679.2       

 

Overall target statistic 

======================================================================== 

     CIP K =  2            Avg  |  SD   |  Max  |  Min  | Delta | Avg +  

------------------------------------------------------------------------ 

Impact Mean Point Xm   :  - 58  |    4  | - 53  | - 63  |   10  | 

Impact Mean Point Ym   :  - 38  |   24  |  - 8  | - 67  |   59  | 

Radius Rm              :    23  |    7  |   34  |   16  |   17  |   38 mm 

Radius R100            :    55  |   32  |  101  |   28  |   73  |  119 mm 

Radius R50             :    20  |    8  |   31  |   14  |   17  |   35 mm 

Radius Rdisp           :    42  |   20  |   71  |   24  |   47  |   83 mm 

Diameter 2R100         :    84  |   41  |  142  |   48  |   93  |  165 mm 

Group Rect. Width  (W) :    50  |   13  |   63  |   38  |   26  |   75 mm 

Group Rect. Height (H) :    76  |   41  |  134  |   44  |   90  |  159 mm 

Group Rect. Sum W + H  :   126  |   47  |  192  |   44  |  148  |  220 mm 

Largest Distance       :    83  |   41  |  142  |   45  |   96  |  166 mm 

 
There is Overall statistic , on the top part. It is built from 
results in Computing window. These variable are in the 
single columns: 
Avg:  average value of measured variable 
SD :  standard deviation 
Max:  maximal value 
Min:  minimal value 
Delta:  dispersion ( = |Max – Min| ) 
Wk [J]:  energy of the round (only for velocity) 
CIP K:  value of C.I.P. coefficient 
Avg +:  corrected value ( [Avg +] = [Avg] + [CIP K]  

x [SD] ) 
Avg –:  corrected value ( [Avg –] = [Avg] – [CIP K]  

x [SD] ) 
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There is Overall target statistic on the bottom part. The 
rows represent final values, statistically processed according 
to previous paragraph: 
 
Impact Mean Point Xm:  mean point of hit – X coordinate 
(for statistical method it is calculated as normal (mean) 
value of X coordinates, for graphical method then for 
example for 10 hits it lies in half of distance between 5th. 
and 6th. hit, resp. for 11 hits it lies in 6th hit, calculated in 
direction of X axis). 
Impact Mean Point Ym:  mean point of hit – Y coordinate 
(for statistical method it is calculated as normal (mean) 
value of Y coordinates, for graphical method then for 
example for 10 hits it lies in half of distance between 5th. 
and 6th. hit, resp. for 11 hits it lies in 6th hit, calculated in 
direction of Y axis). 
Radius Rm: radius of mean circle (i.e. circle with the center 
(Xm,Ym) and radius which is equal to mean value from 
distance of each hit from the point (Xm,Ym)). It is not 
generated for graphical method. 
Radius R100: radius of smallest circle with the center 
(Xm,Ym), containing all hits. 
Radius R50: radius of circle with the center (Xm,Ym), 
containing one half of hits (if it is for example 10 shots, the 
circle has radius of mean value of distance of 5th and 6th hit 
from center, resp. for 11 hits it passes directly by 6th hit). 
Radius Rdisp: radius of smallest circle, containing all hits. 
Diameter 2R100: diameter of smallest circle, containing all 
hits. 
Group Rect. Width (W): distance of outer hits in direction 
of X axis 
Group Rect. Height (H): distance of outer hits in direction 
of Y axis . 
Group Rect. Sum W + H: sum of previous both results (one 
half of perimeter of smallest rectangle, which contains all 
hits and it is oriented in direction of X and Y axis). 
Largest Distance: largest distance between any two hits. 
 
The difference between statistical method and graphical 
method. 
Statistical method calculates with the center of hits, while 
graphical method calculates with internal / external contact 
of penetrations (when caliber is positive / negative 
number) - calculated values are corrected by caliber 
(diameters and distances), resp. one half of caliber 
(radiuses). 
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	Introduction
	Please take the time to thoroughly read this instruction manual. It will help you with the installation, maintenance, and use of this product.
	To the extent permitted by law Kistler does not accept any liability if this instruction manual is not followed or products other than those listed under Accessories are used. 
	Kistler offers a wide range of products for use in measuring technology:
	 Piezoelectric sensors for measuring force, torque, strain, pressure, acceleration, shock, vibration and acoustic-emission
	 Strain gage sensor systems for measuring force and torque
	 Piezoresistive pressure sensors and transmitters
	 Signal conditioners, indicators and calibrators
	 Electronic control and monitoring systems as well as software for specific measurement applications
	 Data transmission modules (telemetry)
	Kistler also develops and produces measuring solutions for the application fields of engines, vehicles, manufacturing, plastics and biomechanics sectors.
	Our product and application brochures will provide you with an overview of our product range. Detailed data sheets are available for almost all products.
	If you need additional help beyond what can be found either on-line or in this manual, please contact Kistler's extensive support organization.
	2. Important Information
	2.1 Disposal Instructions for Electrical and Electronic Equipment

	Do not discard old electronic instruments in municipal trash. For disposal at end of life, please return this product to an authorized local electronic waste disposal service or contact the nearest Kistler Instrument sales office for return instructions.
	2.2 Software Upgrades and Updates

	Kistler may from time to time supply upgrades or updates for embedded software. Such upgrades or updates must always be installed. 
	Kistler declines any liability whatsoever for any direct or consequential damage caused by products running on embedded software which has not been upgraded or updated with the latest software supplied.
	3. Basic Characteristic of TR 2519
	Kistlers' measurement and data evaluation philosophy are the difference between ours and other ballistic analyzers on the market.
	Standard analyzers are produced with rigid input configurations and limited measurement capabilities, which creates a high expense for any changes needed.
	The Kistler analyzer, is fully customizable and has no fixed input configuration, making it easily adaptable for current and future applications.  A nearly unlimited number of ballistics applications are possible, thanks to the Windows® based evaluation method.
	Fig. 1: Transient recorder Type 2519A...
	The Transient Recorder Type 2519 was developed to fill the need for an energy efficient compact unit that provides maximum flexibility. 
	The following comparison chart points on the considerable differences in construction from the limited conventional ballistic analyzers and the Kistler Type 2519:
	Microsoft Windows® is a registered trade mark of Microsoft Corporation.
	3.1 Structural Design of Transient Recorder

	 The standard conventional BA's are formed from the special PC card (this using requires desktop PC). This card is connected with external block of charge amplifiers and with the next adaptors. The pressure measuring is performed by means of two channel AD converter with memory, the velocity measuring is performed by means of start/stop counter. The signal processing for start/stop signal generating (mostly impulses from optical gates) and for initiating of measuring by means of accelerometer make the trouble, because the input modules are sensitive for signal quality and for correct threshold adjusting. The diagnostics is complicated because BA do not make course of signal viewing possible from digital inputs and that is why it is necessary using a digital oscilloscope. This increase the costs of BA operation and through-going check during firing is problematical. The number, type and channels using is fixed by instrument design and this will make only standard measuring possible (designated by producer)
	 This TR 2519 is compact small instrument, which is built from block of power supplies and from industry computer of miniature dimensions, from eight identical AD converters (next only ADC) and from eight removable input cards. The instrument control is provided via Ethernet connection from PC compatible (desktop, notebook, panel PC). The measuring of up to four pressure courses is performed by means of first quad of ADC and charge amplifiers. The next four ADC are used for connecting of miscellaneous voltage signals (accelerometer, muzzle sensor) or for measuring of velocity/accuracy by means of up to six gates. The gates may have digital or analog output (this can be used for display of bullet pass through the gate). Every TR 2519 channels saving input courses of digital and analog signals and that is why TR 2519 replacing diagnostic instruments incl. digital oscilloscope and make more easy failure localization possible during working operation. Channel using is not given sternly and this provides for user higher variability in method connection and used sensors
	3.2 Mobility and Power Supply Possibilities

	 Standard BA is usually a large instrument (incl. desktop PC) and so the mobility and terrain using is problematical. Excessive shock proof is also usually bad. Power supply is possible only from electricity line and power consumption reduces instrument using in terrain 
	 TR 2519 is designed for mobile using - small dimensions, resistance against the shocks, internal air circulation and so resistance against the dust, small power consumption 30 W at 12 V (24 V version is possible according to customer request). Notebook is best way for mobile using as control computer, but thanks to Ethernet connection (galvanic isolated connection) it is possible to use any computer with Ethernet card
	3.3 Transient Recorder 2519 Control

	 The functions are controlled partial manually and partial from control program. So it is impossible instrument adjustment according to method, which is stored on the control computer disc. The requirements for operating personnel are higher and possibility making mistake during measuring or during instrument configuring is also high
	 All functions in TR 2519 are called from virtual machine in MS Windows® environment. User friendly environment make possible several ways for saving complete TR 2519 configuration including data evaluation method and output protocol format
	3.4 Graphical and Numerical Data Evaluation and Output Protocol Format

	 The software does not provide many ways for performing alternative data evaluations than standard thanks to fixed hardware configuration and output protocol about shooting is also given
	 A different approach has been choosen for this instrument thanks to its connection variability to the system. The first there are configured basic parameters (sampling rate, triggering conditions, charge amplifiers ranges) and the single round is fired out. According this shot it is performed the setting of required calculations between any channels and final method is stored on the disc for future measuring. It is also possible shooting the whole shot series during continuous numerical outputs checking. The correction of calculations setting is possible during shooting, after shooting and in the future. The difference between standard process and this process is in the possibility to correct conditions for shot calculation, when the threshold setting for velocity measuring was incorrect. The shot is lost in conventional system. The data in output protocol about shooting are changed in dependence on the calculation settings. The protocol is available in three forms - full and short for all shots and short for current shot. The truncated protocol is generating directly in Microsoft® Word format
	3.5 Calibration

	 The manufacturers are not usually interesting in production of calibration instruments for charge amplifiers or they are making devices for manual calibration. So the calibration process is exacting for control and takes a several hours of work
	 The TR 2519 has implemented manual calibration of charge amplifiers and automatic offset calibration of all inputs. Thanks to connection with 6-channel charge calibrator QC04 it is able calibrating automatically all charge amplifiers during 30 minutes. The protocol is generating about every calibration process and it is stored on the control computer disk
	4. User Manual
	4.1 List of Used Abbreviations and Terms

	TR 2519 Transient Recorder Type 2519
	BA Ballistic Analyze
	AD Analog to Digital
	ADC Analog to Digital Converter
	IM Input Module (charge amplifier etc.)
	A, B, ... Channel 0, Channel 1, ....
	Channel one of eight strings built from input unit and ADC with memory
	Input input BNC connector, one IM can  have several inputs
	Record data from single channel within single  round (single shooting)
	Round one shot, which is stored on the disk  as single data file under the name  BADatNNN.dat (where NNN= 000 -  250) and it contains all eight records  from single channels
	Series more shots, which are stored in single  directory with user’s defined name of  series
	4.2 TR 2519 Installation
	4.2.1 Safety Precautions for Working with TR 2519 Instrument


	 Only qualified personnel may work with TR 2519. Producer is not responsible for any accidents caused by unqualified personnel
	 If the TR 2519 or its equipment works improperly or if the instrument indicates any failure symptoms, do not use it! Replace the cable or power supply, send TR 2519 for repairing to repair service!
	 The TR 2519 is assigned for DC power supply with nominal voltage 12V (or 24V DC for the relevant instrument modification, see the label on the rear panel).This voltage is not allowed to exceed the maximum value assigned in the chapter C2 Technical parameters of TR 2519. TR 2519 is permanently protected against incorrect voltage polarity, it is not protected against the overvoltage. It is necessary keeping safety precautions, which are assigned in standalone manual for this unit, if this one is used for current supply. Working personnel must keep valid safety precautions for handling with electro-technical devices
	 Cooling of internal electronic components is ensured by means of heat conducting through the case of the instrument. It is necessary to ensure free air circulation around this instrument. Do not place anything on the instrument case!!!
	 Respect working temperature range (see chapter C2 Technical parameters of TR 2519 )
	 Never connect higher voltage than nominal to the input connectors (see chapter C2 Technical parameters of TR 2519)
	 In case of installation and TR 2519 operation keep the instructions for handling with ESD (Electrostatic Sensitive Devices). Protect it against static electricity, because the instrument contains sensitive integrated circuits. Never touch the connector pins and discharge yourself from static electricity before connecting/disconnecting connectors
	 The instrument must be protected against the moisture, rain, temperature extremes (storage temperatures below –20 °C and above 40 °C) and temperature and mechanical shocks. The instrument is not allowed placing to direct sunlight, near thermal sources and heavy electromagnetic field sources, to the environment with aggressive chemicals, flammable and explosive vapors and gasses. Keep appropriate instructions against the fire
	 If the TR 2519 is moved to another environment with different temperature than 5°C, it is necessary to adapt the temperature difference sufficient time. Do not turn instrument on, if condensation is appears!
	 Turn instrument off, if you will not make the measurement for the current day! Do not let the instrument turning on without checking, especially at night!
	 Disassembling or modification of the instrument is not allowed without previous permission of producer. If you violate these conditions, you lose the warranty. Producer is not responsible for any due accidents!
	 Use only original equipment and spare parts
	 The instrument can be used only for purpose, for which it was made. Producer is not responsible for any interpretation of measured results and for any accidents caused by their applications in practice. Producer is not responsible for any changes of instrument properties caused with usage or aging
	 The cleaning of TR 2519 is allowed only if the instrument is turned off and disconnected from power line. The instrument is allowed cleaning only with dry lint-free cloth. If the instrument is heavy dirty use damp lint-free cloth with few drops of mild detergent or use pure isopropanol. Never use alkalies, acids and organic solvents except pure isopropanol or ethanol! Especially it is dangerous using the solvents, which erode the polystyrene
	 Clean the connectors only with pure isopropanol and let them drying before measuring!
	Pay attention to maximum input voltage of all input modules – see reference manual/technical specifica-tions. Exceeding of maximum values could destroy this instrument.
	4.2.2 Installation of Transient Recorder

	 Before removing from transport cover the TR 2519 must be acclimated by reason of the temperature equalization and minimizing the possibility of humidity condensation inside the instrument. After that it is possible removing the TR 2519 from the cover and placing it to a working place. Check, if the main switch on the rear panel is on the position 0 (off). If not, switch it to off
	 Install power supply for TR 2519 (see the proper manual) and connect it with original cable with the TR 2519. Screw up optimize the nut of connector
	 Connect the TR 2519 (connector Cannon 9 pin) with network card (connector RJ45) by means of delivered nonstandard communication cable. Screw up the screws on the Cannon connector
	 Turn the TR 2519 on by means of the main switch which is located on the rear panel to position 1 (on). This will be indicated by means of green light POWER on the TR 2519 front panel in the section STATUS. After 5 minutes the other lights will be flash (READY, DATA), which indicates correct TR 2519 function. The instrument is ready for use
	 Connect outputs from relevant sensors to the BNC inputs. TR 2519 installation is finished. Now the installation of TR 2519 Control software for transient recorder control to the control computer is remained. See the next chapter
	 Turning TR 2519 off is possible by switching the main switch to the position 0 (off). If the TR 2519 will not be used for a longer time, disconnect it from the power line (see the proper manual for the power supply)
	4.2.3 Installation of Control Software TR 2519 Control

	 The control computer have to fulfill minimal requirements assigned in the chapter “C6 Requirements for the control computer“
	 Insert install CD into the CD drive of control computer, easy copy the folder with file BAControl.exe to disc C:\ and make shortcut to BAControl.exe
	 Check, if the TR 2519 is turned on and ready for measuring (see previous chapter)
	 Check properly installation of the network card hardware and drivers (see manual for computer or network card)
	 Now it is necessary to set up TCP/IP network communication protocol, which is very important for correct function of TR 2519 Control software. For Windows 7 environment it is step-by-step described in the pictures Fig. 2 and Fig. 3. In Fig. 4 it is setting of section Advanced (usually let default settings)
	 Then run TR 2519 Control software. Activate access to other parts of menu Calibration by means of password KIWAG in Calibration > Activate Calibration. Then in calibration menu choose part Calibration > Network and fill the table in accord with table - see Fig. 5 (set IP Address to 10.10.10.11, Port to 222)
	 Restart computer and try communication. Run program TR 2519 Control (shortcut or file BAControl.exe). The option File > New is enabled
	 For the correct communication turn on control computer first and after booting operating system (and after network card initiating) turn the TR 2519 on. If you have a problem, the trouble is probably in the network cards autoconfiguration and with plug and play technology, when the two computers are started at the same time. The communication could be corrupted, when some programs are started with the program TR 2519 Control at the same time (antivirus program or firewall)
	Fig. 2: Network and sharing center
	Fig. 3: Network connection
	Fig. 4: Network settings
	Fig. 5: Network settings
	4.2.4 Problems During the Installation and Their Solution

	 The green light POWER on the front panel does not light
	 Check power supply and cables. In case of the failure replace these parts. If TR 2519 still not works, contact maintenance service
	 The TR 2519 is turned on, the green light POWER  lights, but after the five minutes the lights READY and DATA do not flash, the communication with the TR 2519 could not be established try turn off the TR 2519 and after one minute turn the TR 2519 on. If  the problem persists, contact maintenance service
	 The TR 2519 is turned on, the green light PWR ON  lights and the light READY, DCOMP and DATA flash, but the communication with the TR 2519 could not be established
	 check network card configuration (see chapter B2.3 Installation of control program TR 2519 Control) and restart control computer and TR 2519. (turn off and after one minute turn on control computer first and after booting operating system turn the TR 2519 on). Beware of the conflict with another network card or with some other programs (remove, disable problematical software/hardware). If the TR 2519 still not works, contact maintenance service
	 The communication is lost during measuring process (data transport from the TR 2519 to control computer “freeze“) the solution is as same as for point 3
	 The option File > New is inaccessible after starting TR 2519 Control program or the whole panel of the virtual TR 2519 is not appeared (the panel is missing or panel of input modules are missing) after inserting name of the directory for data saving and after filling initial form
	 if some module misses, the firmware could not established connection with it. If the problem cannot be resolved according to point 3, the module is probably damaged and must be replaced, call service. If all modules are missing or the option File > New is inaccessible, the communication between TR 2519 and control computer was not established and the solution is as same as for point 3
	4.3 Preparing TR 2519 for Measurement

	The whole philosophy about TR 2519 control will be now explained on the following typical ballistic example (from sensors connection to establishment and printing numerical results). If the user will try the measuring according this example, he will be able working independently.
	4.3.1 Typical Connection of Sensors to TR 2519

	The basic EPVAT & Accuracy measurement is in the following picture (Fig. 6):
	Fig. 6: Connection scheme
	EPVAT & Target System Results
	 Graph and max value of chamber pressure
	 Graph and max value of port pressure
	 Graph and max value of muzzle pressure
	 Velocity (any combination of muzzle, two gates and target)
	 Action time
	 XY position of shot at target system
	 Target velocity and energy of bullet
	4.3.2 Connecting Cables and Connectors

	The sensors are connected to TR 2519 by means of coaxial cables with BNC connectors. It is recommended to use only original cables from manufacturer for signal transfer from piezoelectric pressure sensors. Although this TR 2519 has circuits for compensation of cable leakage, it is necessary to keep all connectors clean and never touch the pins with the finger. The connectors should have only Fluoropolymer insulation and the cables high-quality dielectric with respect to used temperature range.
	4.3.3 Recommendations for Choosing and Using Single Channels (Inputs)

	The channels A – D CHARGE AMPLIFIERS have always single input and serve for piezoelectric pressure sensors connection. The channels E – H VOLTAGE INPUTS have either two inputs and they are used for common using for measuring of voltage signals in the range ±10 V. Signal of all two inputs of one channel is added and digitized by one ADC. These inputs are mostly used for connection of accelerometer or flash detector and for measuring of velocity and accuracy by means of optical gates. You can connect the gates with digital or analog output (displays the pass of bullet through the gate). You can use other sensors for example electromagnetic rings if meets voltage inputs range (the sum within the two inputs is max. ±10 V, in detail see technical parameters). These inputs can be used for connecting the other sensors, for example impact board (for signal recording during the shot impact on the target).
	There exists three groups of processes in dependence on time duration. The first group is relatively short (Internal Ballistics) – it is the time interval from the ignition to the time, when the bullet leaves the barrel. The second two groups are considerably longer – it records the flight (External Ballistics 1) and impact of the bullet on the target (External Ballistics 2).
	Transient Recorder always records all 400 000 points into internal high-speed memory. TR 2519 Control software allows adjust the interval of transferred data separately for the every pair of channels A+B, C+D, E+F, G+H and user can assign every channel into corresponding graph of Internal Ballistics, External Ballistics 1 or External Ballistics 2. The time intervals are fully independent to each other, overlapping is not necessary. This considerably improves speed of TR 2519 Control software and reduces a quantity of transferred data, because software transfers only data with true measured impulses.
	Pay attention to maximum input voltage of all input modules- see reference manual/technical specifica-tions. Exceeding of maximum values could destroy this instrument.
	4.3.4 What Data Will Be for Given Arrangement

	Standard TR 2519 is usually connected in the way that Chamber Pressure (Pc) signal starts the measurement (most reliable triggering).
	Optical gate for measuring of velocity V10 is placed in distance 10m from muzzle (distance 10m is between muzzle and center of optical gate base). Optical target system for measuring of velocity V25 and accuracy T25 is placed in distance 25m from muzzle (distance 25m is between muzzle and center of optical target base).
	This TR 2519 works on differently than other analyzers. It does not give any numerical readings directly, but it measures the real dependencies of all type of signals first. By means of the method, which is created in the program TR 2519 Control, it calculates from those dependencies needed numerical readings for any combinations of input signals. The following output data can be directly acquired for assigned TR 2519 connection:
	 waveform of chamber pressure Pc
	 waveform of port pressure Pp
	 waveform of accelerometer signal
	 waveforms of velocity gate signals (Start a Stop)
	 waveforms of target system signals (X a Y)
	By means of created method TR 2519 control calculates these numerical results:
	 value and time of maximum chamber pressure Pc
	 value and time of maximum port pressure Pp
	 velocity V10
	 velocity V25
	 coordinates and statistical evaluation of every shot T25
	It is acquired the review about velocity in dependence on the trajectory (it is possible to calculate drop of velocity and V0). Besides, it can be continuously checked the signal quality from all sensors and in case of some anomaly it is possible determining the cause of anomaly. If the numerical outputs are false, the round need not be repeated, but you can only modify the method.
	4.3.5 Preparing TR 2519 for Measurement

	 Connect all cables from sensors with relevant TR 2519 inputs (see previous chapters)
	 Check if TR 2519 is connected with control computer network card. If not, connect TR 2519 and control computer with this cable (9-pin Cannon – RJ45 connector). Screw the Canon connector screws
	 Turn control computer on and wait while operating system is loaded
	 Turn TR 2519 on with the switch (rear panel).This will be indicated on the section STATUS DISPLAY by POWER light. After a max. 5 minutes the other lights will be flashing (READY, and DATA), which indicates correct function
	 Run program TR 2519 Control. It appears the main program window and if program is started for the first time, it is necessary to adjust its working directories. This is possible in Settings > Directories (Fig. 7) by assigning the whole path or by listing  existing directory. The content of single directories is following:
	- Data   - measured data 
	- ASCII export  - data output in ASCII form
	- Settings (Methods) - TR 2519 setting (methods)
	- Reports   - measured results in the
	   protocol forms
	- XLS Reports  - measured results in the XLS
	  protocol forms
	- Calibrations  - calibration protocols
	- References  - reference curves
	- Report Forms  - C.I.P. forms
	- Sensors   - sensors for TR 2519
	- Data Backup  - directory for data backup
	- Temporary  - temporary files
	Fig. 7: Directories settings
	 Check Settings > Colors, Preferences (Fig. 8 and 9). The reason of single items will be explained later, the setting should be according the picture. Grey (inactive) items has noeffect and their adjustment does not matter. Then it is necessary to assign channels A - H into relevant graphs by means of button according to picture Fig. 10
	Now the preparations for measuring are done.
	Fig. 8: Basic settings
	Fig. 9: Basic settings
	Fig. 10: Graph organizer
	4.4 Measuring Procedure, Method and Protocol Building

	If TR 2519 is ready (see previous chapter), it is possible to start measuring. It is recommended keeping the following method :
	 Entering of name of measured series and filling of form
	 Setting of main TR 2519 parameters
	 Shooting of first round
	 Building of data evaluation method
	 Shooting of the whole rounds of series
	4.4.1 Entering of Name of Measured Series and Filling of Form

	For each new series it is necessary to enter the name of series and also select directory for saving of data (if directory is different from default directory). In the main window of program TR 2519 Control select File > New or use the button   and type required name of series (or use Browse… for different directory). 
	Fig. 11: Directory and name setting
	The single data files will be stored in the directory :
	C:\BA_Data\2009-12-02_5.56x45 NATO H823 – 003
	where: C:\BA_Data ... directory (see Settings > Directories)
	 2009-12-02_5.56x45 NATO H823 - 003 ... name of series (min. 4 characters!).
	Attention!
	MAXIMUM NUMBER OF SHOTS IS LIMITED TO 250.
	Browse... serves for changing of data storage directory.
	If you choose the name of existing series, after prompting and confirming with Yes  answer, the existing data will be replaced with the new data.
	Fig. 12: Confirmation
	After the new name of series setting it appears the configurable form (Fig. 13 and 14). Its filling is not required and can be completed later (see standalone chapter for detailed description). After confirming Yes, the configuration file is loaded from the instrument and TR 2519 virtual panel appears.
	Fig. 13: Definition of report
	Fig. 14: Definition of report
	4.4.2 Setting of Main TR 2519 Parameters

	Setting of all TR 2519 parameters and its measuring control is made by means of virtual TR 2519 panel.
	Fig. 15: Virtual panel
	Before first round it is necessary adjusting following TR 2519 parameters:
	Sampling rate (Sample Rate) determines the number of points of input signal (pressure etc.), which are recorded for every second. Its setting has effect for density of points on the final graph. Too high density made data processing slower and the large files are created on the disk. According to C.I.P. specifies the minimal sampling rate 1MHz, which is usually used method in practice for pressure measuring of powder gases. 
	Trigger level (Trigger Level) is the specific value. After exceeding this value the TR 2519 data recording is initiated. This value is pictured in percent of given range. For negative values has blue color, for positive values has red color and for zero value has green color. Set optimal trigger value for secure triggering without possibility of false triggering caused by noise and interference (and that is why the level 0.00% is not used during pressure triggering). Recommended value for typical measuring is 12.5%.
	Trigger edge (Trigger Edge) determines, while data recording initialization will be followed after trigger level exceeding (Trigger Level) during signal increasing (RISE) or during signal decreasing (FALL).
	This buttons serve for Transient Recorder setting (Settings) and make loading possible (LOAD) and saving (SAVE) on the control computer disk. Detailed description – see relevant text.
	Fig. 16: Saved data
	Virtual TR 2519 display provides important information about the setting and TR 2519 measuring procedure. There is the name of directory on the left topside in the first row (Name, Series), where the data will be stored, and the volume of total saved data in this series (Saved Data). There is the round counter on the right topside (Round), the number 0 means, that neither round was recorded so far.
	For understanding of function of other settings it is necessary explaining TR 2519 operation with the memory of AD converters. This memory is always filled with data in the range –100 000 to +300 000 points. The negative numbers are the so-called pre-trigger, i.e. the data which are recorded before recording initiation, zero is the time of triggering and positive numbers are data after recording initiation. For typical work are 400 000 points too many and that is why only required part of data are transferred to control computer. This part is set-up separately for every pair of channels A+B, C+D, E+F and G+H (see chapter B 3.3 Recommendations for choosing and using single channels (inputs)) The beginning of memory reading is located on the left part of display, the end is on the right. The adjusted data are displayed for checking by bar graph form. The vertical red line indicates time of triggering (Trigger point).
	In the second line of display are written calculatíons of transported points and lengths of time intervals for every pair of channels (Record) and total volume of data for the one round.
	Free horizontal line in the center of display is used for bar graph displaying with data transport process from TR 2519 to control computer.
	There are the buttons for TR 2519 measuring control in the right part of virtual TR 2519 panel. Their functions are : delete last round (DELETE), run  measuring (RUN), stop measuring (STOP), automatic measuring of the whole series (AUTO) and testing of inputs (TEST). The button RUN has a second function READ (for reread of TR 2519 data after modification of time intervals at first round of series) and the button STOP has a second function BREAK (interrupt of long measurement by using low sample rate). The function of those buttons will be described later during measuring.
	Fig. 17: Scheme of recording
	Fig. 18: Scheme of reading
	Fig. 19: Parameter setting
	The panel of input module – charge amplifier.
	A CH0 - the marking of channel, color is the same as color of curve in graph.
	Charge amplifier IM06-0-CHGA - the name of module.
	Four lines of free text - text field for placing description of relevant channel for better orientation of user (sensor type, its using, location on the weapon i.e.).
	Trigger - the switch for the trigger channel selection. Selected channel is highlighted with the red color. We recommend to choose the pressure channel as the triggering source, because by contrast to accelerometer it provides clear course with defined and almost constant shape and it is very resistive against the false triggering.
	Setting of calibration constant of sensor - button for setting of the pressure sensor calibration coefficient. For entering of sensor coefficient press this button and select item from menu :
	– Load is for loading of saved sensor parameters
	– Save is for saving of actual sensor parameters
	– Parameters serves for direct entering of sensor parameters in exponential form
	(button Inverted inverts the sensor polarity - for sensors with negative calibration coefficient let this button inactive). [pC/?] means user defined unit (different from previously defined).
	Range 2 600 pC, 5 200 pC, 10 600 pC, 20 200 pC - the selection of measuring range. Beside the title Range is displayed calculated value of measuring range in bar units (depends on the selection of measuring range and on the sensor calibration coefficient - provides information about true maximum pressure).
	Filter 10 kHz, 20 kHz, 40 kHz, Off - the filter selection.Auto-zero on, Auto-zero off - the switch of automatic compensation of the offset and the cable leakage. Normally use only Auto-zero on, do not set this switch to Auto-zero off. This provides maximum measuring accuracy by changing of temperature and other ambient conditions. Only for measuring of pressure process which are longer than 100 ms it is necessary to disable this function (Auto-zero off), because compensation causes distortion of measurement.
	Apply  - serves to send of actual settings into TR 2519.
	The panel of input module - universal voltage input.
	E CH4 - the marking of channel, color is the same as color of curve in graph.
	Voltage input IM07-0-D2SA - the name of module.
	Four lines of free text - text field for placing description of relevant channel for better orientation of user (sensor type, its using, location on the weapon i.e.).
	Trigger - the switch for the trigger channel selection. Selected channel is highlighted with the red color.
	Range 1 V, 2 V, 5 V, 10 V - the selection of measuring range. Because this module has three summing inputs, the range means sum of three input voltages.
	Apply  - serves to send of actual settings into TR 2519.
	4.4.3 Shooting of First Round

	If basic TR 2519 parameters are adjusted, it is possible running measuring. If the measuring is new, it usually does not contain the method for data evaluation. You have to shot first round and make setting of those data evaluation for the whole series. If the testing weapon is ready for first shoot, click on the button RUN, which is located to the right topside. The button AUTO is not allowed to be pressed.
	At first the control computer sends the information for setting of TR 2519 and then TR 2519 reads data for pretrigger (Fig. 20 and 21). After a several second it is displayed the information about waiting for trigger (Waiting for trigger, Fig. 22). The button RUN is now disabled, the measuring (waiting for trigger) can be aborted by enabled button STOP.
	Fig. 20: Run first round
	Fig. 21: Reading data for pretriggering
	Fig. 22: After pretriggering: stop
	On the front panel of TR 2519 lights the red light READY. This indicates finish recording of pre-trigger and TR 2519 is ready for recording of round. When the light is on, you can shot the first round. Correct capturing of triggering is indicated by the lettering Trigger OK.
	Fig. 23: Shoot of first round
	The transport of data to the control computer is indicated by green light DATA. Data are sent separately for each pair of channels (see green bar graph).
	Fig. 24: Saving data
	Successful transport and graphs drawing are indicated with the round counter incrimination (Round) and with the counter of saving data volume (Saved Data). The button RUN is enabled at the same moment for next shot of series and DELETE for deleting of the last round of series.
	Fig. 25: Saved round
	In this phase the data are stored on the control computer disk and it is possible to create the method for numerical evaluation of curves. It is necessary to create the method after the first round of series, because creating or modifying of method is disabled from the second round and it is possible to edit some parameters only. The method can be changed after finishing of measurement.
	Description of functions is simplified and special functions (correction of time interval with rereading of data, interrupting of measurement with low sampling frequency etc.) are described in reference part of TR 2519 manual.
	4.4.4 Building of Data Evaluation Method 

	Display of control computer now includes virtual TR 2519 panel and main program TR 2519 Control window.
	Fig. 26: Measuring graph
	While TR 2519 virtual panel controls the instrument during measuring, the main window of TR 2519 Control program integrates all functions of program (measuring, data displaying and processing) to single complex. Creation of method for data evaluation is also performed in this window.
	It is necessary to know several actions for successful creation of method - setting of graph (axis and colors), displaying and hiding of curves, switching of graphs and zoom function (Zoom). These functions are called from the main window of TR 2519 Control program.
	Setting of graph scales is accessible in Preferences > Scales and contains setting of scales of all Y­axes (Fig. 27). The option Auto sizes axes according to founded curves minimum and maximum.
	Fig. 27: Settings of graph scales
	If you want to choose fixed axis scale, uncheck option Auto and type choosen value of curves minimum and maximum. The possible result is displayed on the Fig. 28. Automatic scaling of axes can be temporarily enabled by means of button   /.
	Fig. 28: Graphs A – D/E – F/G – H
	Other possible settings are on the picture Fig. 29, 30 and 31 (during measurement are accessible only some options - for detailed description see TR 2519 reference manual).
	      Fig. 29:  Graph settings
	Fig. 30:  Graph settings
	Fig. 31: Graph settings
	Displaying and hiding of curves
	    ////////
	 by means of buttons with the symbol of eye, which are located at the left topside margin of main program window (beside the graph).
	// If eye button has highlighted color, the curve is displayed. If you press this button, the color has to be dull and the curve is hidden. When you click on the button again, the curve will be displayed.
	Graph switching is possible by means of switch in tools panel of main program window :
	  graph of Internal Ballistics
	  graph of External Ballistics 1
	  graph of External Ballistics 2
	  graph of Internal Ballistics - Statistics (inaccessible during measuring)
	Zoom is the next function of program. Selection of the curve, which is displayed in separate window Zoom, is made by means of zoom switches beside the buttons for curve displaying and hiding. The function Zoom is allowed only for displayed curves /, it is prohibited for hidden curves. Active function Zoom is indicated with change (activating) of zoom button in tools panel /, after its deactivating the function Zoom is deactivated.
	After Zoom activating it is opened in a separate window (Fig. 32) with the  selected part of the curve. This part of selected curve is terminated with horizontal and vertical cursors and highlighted with color in the main program window (color setting see Settings > Preferences > Graph colours > Selected area). It is possible to drag&drop the cursors by means of mouse and changing magnification of relevant part of curve in the window Zoom.
	The buttons / /  serves for locking and unlocking of relative cursor position for easy examination of curve details (it is possible moving with the pair of locked cursors at the same time).
	Fig. 32: Zoom function
	Creation of method for data evaluation is activated and deactivated by means of button / Computing, which is located at the panel of tools of main program window.
	Make all required curve displayed on all graphs by means of previously described functions and adjust their imaging according to your requirements. Then press the button of function Computing. It appears empty window for creation of method for data evaluation. It contains group of control buttons  (Fig. 33). If the window is not empty it is possible to delete all lines by means of button  / Delete all.
	Fig. 33: Creation of method
	The first line of method will be maximum pressure determination on the A curve (red). Press the button   Add pressure, which serve for addition of single line with calculation of pressure maximum and relevant data times.
	Fig. 34: Definition of method
	Meaning of single line items :
	Row: line number. Checkbox determines addition of results to reports.
	Type: icon for identification of function of line (Pmax)
	Start / Interval: up - button for setting of beginning of Pmax time admeasurement
	down - button for setting of interval for calculation of Pmax
	Edge: setting of evaluation from rise or fall edge of impulse
	Min. width: setting of minimal accepted width of impulse
	Description: naming of this line (any text)
	Results: time to Pmax and value of Pmax
	Extended values and results: calculation of time to adjusted pressure level (%Pmax)
	Limits (Max/Min): settings of limit values of Max(Pmax) and Min(Pmax)
	C.I.P. coeff.: calculation of C.I.P.correction (setting of correction coefficient)
	NATO coeff.: calculation of NATO correction (setting of value for correction of result)
	Press button Start OK and for transition to /edit mode press the button   Edit. This open the window Zoom, where it is displayed highlighted area of selected curve, which is limited with vertical cursors. The button on the number and its color is corresponding of color of selected curve. Choose required curve by means of button with symbol of magnifying glass /. Because the beginning of time admeasurement for maximum pressure is given with accelerometer, choose the curve C. Then choose by means of vertical cursors required area and by means of single horizontal cursor, which represents threshold level, set its point of intersection with the curve. This cursor is drawndrawn also in the window Zoom and founded point is highlighted. The relevant computed value of time is inserted to the window Computing. For accept of this setting press the button / Apply to all - edit mode is cancelled and setting is stored. If edit mode is leaved with other way, the setting ís ignored! For cancel of edit mode without saving press the button  /Escape .
	Next choose appropriate edge of impulse (Edge) and press the button / . Similar is setting of minimal width of impulse (Min. width).
	Fig. 35: Window zoom
	The next point in sequence is setting of interval for calculation of maximum pressure Pmax. Press the button Interval OK to choose setting of this interval and by pressing button  / Edit go to edit mode. At first select appropriate curve of channel A by pressing button with symbol of magnifying glass   /and select the area for searching of maximum pressure with vertical cursors  Horizontal cursor is not presented here. Founded maximum is highlighted at the window Zoom. Into the area Results are written time of maximum Pmax from beginning (here impulse of accelerometer) and value of maximum pressure Pmax.
	For accept of this setting press the button   /Apply to all (edit mode is cancelled and setting is stored).
	Next select length of filter for noise suppression by searching of maximum value of pressure in column Min. width (maximum value is calculated as average value of preset area - default value is 1, zero means Filter Off). For accept of this setting press the button   /Apply to all.
	Fig. 36: Calculation of maximum pressure
	Type any text to the field for naming of line, which characters measured quantities and will serve for their identification (Fig. 37). Accept with the button / Apply to all .
	The next point is calculation of the time, which is needed for reach of adjusted level of pressure (in percent of found maximum pressure). For activation of this function check the box and adjust required pressure level. In results area appears calculated time. For accept of this setting press the button / Apply to all. The work with C.I.P. / NATO corrections is activated and filled with the same way as the previous items.
	Fig. 37: Calculation of time
	The first line building for pressure curve evaluation is finished.
	If you want to edit setting, choose it the appropriate item, then by means of Edit go to edit mode, correct cursors setting and for finishing of edit mode use button Apply to all for saving of changes or Escape for keeping of previous setting. For editing of other setting the edit mode is not needed, but after inserting of new value use always the button Apply to all or Escape.
	Analogical to the first line is filled the second line for the curve B (blue).
	Third line of method will be contain assignment of time interval, the so-called Action time. Press button / Add time/velocity, which serves for addition of single line with calculation of time interval and after set of base size also for calculation of velocity.
	Fig. 38: Calculation methods
	Meaning of single line items :
	Row: line number. Checkbox determines addition of results to reports.
	Type: icon for identification of function of line
	Start/Stop: up - button for setting of time admeasurement start
	down - button for setting of time admeasurement stop
	%: button for selection of horizontal cursor mode (absolute
	position in units according to axe or relative position in
	percent of maximum value in selected interval)
	Edge: setting of evaluation from rise or fall edge of impulse
	Min. width: setting of minimal accepted width of impulse
	Description: naming of this line (any text)
	Results: calculated time interval
	Extended values and results: option for calculation of velocity by entering:
	 up - distance of first gate of given pair from muzzle 
	 down - size of base for measuring of velocity (distance between pair of gates)
	Limits (Max/Min): settings of limit values of Max(time,
	velocity) and Min(time, velocity)
	C.I.P. coeff.: calculation of C.I.P.correction (setting
	of correction coefficient)
	NATO coeff.: calculation of NATO correction (setting
	of value for correction of result)
	Press button Start OK and for going to edit mode also the button / Edit. At first choose required curve of channel A by pressing button with symbol of magnifying glass /. Because the beginning of time admeasurement for Action time is given with accelerometer, select curve C. Then select required area by means of vertical cursors and by means of single horizontal cursor, which represents threshold level, adjust its point of intersection with the curve. This cursor is drawn also at the window Zoom and founded point is highlighted. The relevant calculated value of time is inserted to the window Computing. For accept of this setting press the button / Apply to all - edit mode is cancelled and setting is stored. If edit mode is leaved with other way, the setting is ignored! For cancel of edit mode without saving press the button/ Escape .
	Next choose appropriate edge of impulse (Edge) and press the button /. Similar is setting of minimal width of impulse (Min. width).
	Fig. 39: Action time
	Continue with setting end of time of the measurement. The setting process is as analogical as at previous point.
	After setting of begin and end of time interval is written the result – calculated time interval.
	The next point is filling of naming of this this line. After finishing this procedure it is necessary to use the button Apply to all.
	Then it is possible to continue in calculation of velocity from measured time interval (this function is not used here). For activation of this function check the box and adjust required distance of first gate of relevant pair from the muzzle and the size of measuring base. In results area appears calculated velocity. For acceptance of this setting it is necessary to use button Apply to all.
	Similarly it is possible to enter limits and C.I.P. / NATO corrections.
	Final building of first three lines you can see at the Fig. 40.
	Fig 77:
	Fig. 40: Time interval
	Building of the next lines at the window Computing is analogical to the procedure, which has been explained for the first three lines. Small change is only in fact, that this is measuring of velocity and that is why this function is always activated together with set of relevant entries. 
	The following pictures show also the signals from optical gates. Pay attention to setting of relevant intervals for single gates - it is accepted always only the first exceeding of horizontal cursor in adjusted interval in selected direction: first rise edge from right or left side or first fall edge from right or left side.
	Line No. 4 – velocity measurement (optical gates – first gate start, second gate stop).
	Fig. 41: Velocity measurement
	Fig 83:
	Fig. 42: Velocity measurement
	Line No.5 – measurement of accuracy and velocity by means of electronic target system. Detailed description is in separate chapter.
	Fig. 43: Accuracy and velocity
	Fig 89:
	Fig. 44: Accuracy and velocity
	Summary of functions at the window Computing :
	/ - (1) Add Time/Velocity - calculation of time
	and velocity
	/ - (1) Add t/v integral - calculation of time and velocity by means of integral (it requires special analog gates)
	/ - (1) Add t/v zero - calculation of velocity from
	zero crossing (derivative sensors, as a AC light gates and electromagnetic rings)
	/ - (1) Add pressure - calculation of the maximum pressure
	/ - (1) Add Y=f(X) - computing of function value for predefined value of X (time)
	/ - (1) Add adv. Y=f(X) - computing of function value at start impulse
	/ - (1) Add Average - computing of average Y value in selected X interval (time)
	/ - (1) Add integral - calculation of integral (between cursors)
	/ - (1) Add adv. integral - calculation of integral (between start/stop impulse)
	/ - (1) Add gradient - calculation of rate of rise (rate of fall) of the curve
	/ - (1) Add Rise/Fall - computing of parameters of impulse edge
	/ - (1) Add Mask - mask for checking of shape of curve
	/ - (1) Add Rate Of Fire - calculation of Rate of Fire
	/ / - (1) Add target - calculation of target
	/ - (1) Add user - input of any numeric value
	/ - (1) Add Start-Stop Counter - computing of time/velocity by means of counters
	(BA04SE only)
	/  - (1) Add GPS - reading of GPS (UTC Time and Coordinates) (GPS Garmin, special accessory)
	/ - (1) Add Calculation - computing between result of rows
	/  - (1) Delete row - delete selected row
	/  - (1) Delete all - delete all rows
	/  - (A) Edit - switching of selected row to
	edit mode
	/  - (1) Apply to all - exit from edit mode
	and saving changes (for all round of series)
	/  - (A-1) Apply - exit from edit mode
	and saving changes only for current round
	/  - (A) Escape - exit without saving
	/
	/  - (1) Up, Down - selected line feed
	up/down
	(1) =  accessible only for the round No.1 of
	relevant series
	(A-1) =  accessible for all round of relevant
	series except the round No.1
	(A)            =  accessible for all round of relevant 
	series
	Important advices for building method for data evaluation:
	 During searching of maximum pressure is always founded the point with maximum value in the interval selected with cursors. In the neighborhood of this point (adjusted, default ±5 points) is determined medium value, which represents founded maximum. This filtration is necessary for noise elimination
	 Program approximates measured curve with line in vicinity of intersection with horizontal cursor (which represents threshold level)
	 It is convenient to place threshold level with respect to maximum interference elimination (see Fig. 42 … 47)
	 It is possible to filtrate off undesired interference and fault impulses by setting of time interval for searching of threshold level intersection with the curve, by moving of threshold level cursor, by setting of rise/fall edge and by setting of minimal acceptable width of impulse. This operation is not possible to make at conventional BA and causes false results. By contrast to common threshold setting with trial-and-error method, here it is provided lucid and easy setting in GUI (Graphic User Interface). It is possible to determine all signal anomalous and effectively to intervene - see next pictures:
	Fig. 45: Determination of signal anomalous
	Fig. 46: Determination of signal anomalous
	Fig. 47: Determination of signal anomalous
	4.4.5 Shooting of the Whole Rounds of Series

	After assembling of data evaluating method it is possible to continue in measurement of next rounds of relevant series. There are two options, which can be arbitrarily combined during measuring process:
	 Manual mode (switch AUTO is not pressed) - before every round it is necessary by pressing of button RUN adjust TR 2519 to mode of waiting for trigger impulse. This waiting for trigger impulse is indicated by lettering Waiting for trigger (see Fig. 22) and by lighting of red light READY on front panel of TR 2519. Then it is possible to shot one round
	 Automatic mode (switch AUTO is pressed) - before first round it is necessary by pressing of button RUN adjust TR 2519 to mode of waiting for trigger impulse. This waiting for trigger impulse is indicated by lettering Waiting for trigger (see Fig. 22) and by lighting of red (older versions orange) light READY on front panel of TR 2519. Then it is possible to shot one round. Always if the reading of data is finished, the TR 2519 is automatically set after every round to mode of waiting for trigger impulse and it is possible to shot next round
	Measurement (waiting for trigger impulse) can be aborted by button STOP.
	Last round can be deleted by means of button DELETE, if button is accessible.
	Numerical results can be watched during measurement. This is possible at opened window Computing, where the values are updated after each round including the window Zoom (if window is opened by means of button for setting of some limit - see Fig. 34 and 38).
	The next option is watching of report of measured series / (File > Report measured series), which provides summary information about all rounds of relevant series including statistic calculations.
	Last option is the report of current round / (File > Report actual round), which contains key results about pictured round.
	After shooting of the whole round series it is necessary to abort mode waiting for trigger impulse by means of button STOP (if button is activated) and closing TR 2519 panel means of button / in right topside corner. Measured data will be automatically stored at this moment (data are stored to temporary directory during measuring process and will be copied to predefined data directory after closing of TR 2519 panel) and selected output reports are exported.
	4.5 Work with Measured Data
	4.5.1 Group Organizer, Displaying and Printing of Results


	Program allows dividing of data up to ten groups for interlaced shooting or for comparison of groups of ammunition. Each group is separately statistically processed and the results are again processed to overall report.
	Dividing is allowed by the function Group Organizer, accessible by button /:
	Fig. 48: Group organizer
	In the left column are numbers of rounds and up are names of groups (any text, it will be appeared in title of report). On the top are buttons for quick dividing of rounds to groups:
	All in 1 (all to first group)
	No. of GRP: 2 (one half to 1st group and one half to 2nd group)
	No. of GRP: 3 (first third to 1st group … third third to 3rd group)
	etc.
	No. of ALT: 2 (alternate to 1st and 2nd group)
	No. of ALT: 3 (alternate to 1st, 2nd and 3rd group)
	etc.
	It is possible to modify allocation by means of array of buttons. After closing the window it is automatically performed data recalculation according to actual allocation.
	Checkbox Report determines group, which is put into reports and statistic calculations (unchecked groups are hidden in all reports).
	The results of measurement are:
	a) four graphs 1. Internal Ballistics
	2. External Ballistics 1
	3. External Ballistics 2
	4. Internal Ballistics - Statistics
	b) computed values 1. Target System 1
	2. Target System 2
	3. Reports (pictured and saved on
	    the disc)
	The work with the first three graphs has been described during the measuring process.
	Fourth graph Internal Ballistics - Statistics is not accessible during measurement and contains the data from channels which were placed into graph Internal Ballistics. Software calculates average (AVG), minimum (MIN) and maximum (MAX) curve (“minimum“ and “maximum“ curve are envelope curves of all rounds, “average“ curve is mean value of all rounds). Their displaying or hiding is possible by means of button / / /. It is also possible to show all rounds by means of button /. The reference curve can be pictured by means of the button /, if this one is loaded. It is possible to choose graph of specific group by means of the buttons / - /. If only single group is chosen (pictured), it is possible to save its curve AVG as reference (File > Save ref...) for visual comparison with other measured curves. The other functions are the same as in previous both graphs. It is possible to show report for this statistic graph (File > Report statistics) by means of the button /.
	For each graph exists the list of relevant numerical results according to setting of data evaluation method at the window Computing. The report of current round / (File > Report actual round) is determined for first three graphs and report of statistics / (File > Report statistics) for the fourth graph.
	Report of measured series / (File > Report measured series) contains summary information about all rounds of relevant series including statistic calculations. The data are allocated to the groups, each includes basic statistic calculations (arithmetic average (Avg), standard deviation (SD), maximal and minimal value (Max, Min) and dispersion (Delta)). The summary statistic including corrections of CIP coefficient is placed in the end of report.
	Preselected reports in Settings > Preferences > Misc) (are always stored after finishing of measurement or by data saving on the disc to preset directory - Settings > Directories (Fig. 7). These reports can be easy printed or processed in programs as a MS Word etc.
	Final Report / (File > Final Report…) serves for comfortable direct printing of results (see Reference Manual).
	Each graph can be transferred to another program through the Clipboard (by means of /, Edit > Copy or Ctrl+C), printing of graph is possible by File > Print or Ctrl+P.
	4.5.2 Selection of Single Round and Delete of Selected Round

	It is possible to list between the rounds by means of buttons / or Select > First, Previous, Next, Last). Their function is (from the left) : first round, previous round, direct selection, following round and last round. Selected round can be deleted by means of button / or Edit > Delete. For permanent delete it is necessary to save data on the disc by means of the button / or File > Save, because the program by reason of original data protection works only with their copy.
	4.5.3 Modification of Measured Data Evaluation

	It is necessary to remind basic rules:
	 it is possible changing method setting of data evaluation by means of Computing, i.e. addition and erasing line, text and numerical values changing only during first round of relevant series and this fact has effect for all round of relevant series
	 for second and next rounds it is possible to modify only cursors setting (intervals and thresholds), it is not possible to add or delete line, change the text and numerical values. The changes in setting have influence only for this round
	It follows two consequences:
	 if it is necessary to change the whole method setting, choose round number one and make required modifications as during measurement
	 if you find out, that some numerical value for other than first round in report is not quite correct, choose it and in Computing try to determinate the cause of fault evaluation from the graphs and try to get correct result with cursors moving. This change of setting has not effect for other round series
	If the changes may have permanent character, it is necessary to save data on the disc by means of button / or File > Save, because the program by reason of original data protection works only with their copy.
	4.5.4 Filtering of Data (Built-in Running Average Filter)

	These filters serve to suppression of noise. It is possible to use this filter immediately during measurement or late after measurement. Original data is always retained and data is automatically restored after switch-off filter.
	Filter is activated by use of button / or in menu Graphs and computing > Filters. It appears the window (Fig. 49), which contains setting of running average filter for each channel:
	- checkbox of filter activation
	- setting of filter parameters (number of points for computing of average value - higher number increases efficacy of filtering, but increases distortion of curve). Maximum number of points for computing of average value is limited to 1% of all measured points of relevant curve.
	Channels filtered during measurement are color marked.
	Fig. 49: Filter settings
	Fig. 50: Virtual panel
	4.5.5 Aborting of Shooting and Finishing of Shooting of Other Rounds of the Loaded Data

	Program allows breaking of shooting and finishing of shooting of remained rounds later. The condition is the necessity to use the same method for data evaluation (this is automatically provided). Let’s suppose that data are stored on the disc. They can be loaded by means of button / or File > Open and activate measuring mode by means of Measurement > TR 2519. It is opened TR 2519 panel, which is set according to used method. It is possible to continue with measuring with typical way. When you finish the shot, it necessary to break waiting for trigger impulse by means of button STOP, if button is activated, and close TR 2519 panel by means of button / in right topside corner. It appears the window for data saving with predefined name of current series. You can overwrite previous data with new data (= previous+ new) or save these data under different name. If you choose Cancel, previous data will be kept without change and new data will be stored on the disc only in temporary copy. If you terminate program or you start new measurement (File > New or you use the button/ ), the new data will be lost. Do not forget to save the data on the disc by means of button / or File > Save.
	4.5.6 Function READ and BREAK

	Function READ is accessible only for first round of series. Function READ is accessible after changing of time intervals for reading of data of first round (it substitutes the button RUN in right part of virtual TR 2519 panel).
	Memory of AD converters is always filled with data in the range –100 000 to +300 000 points. The negative numbers are the so-called pre-trigger, i.e. the data which are recorded before recording initiation, zero is the time of triggering and positive numbers are data after recording initiation. For typical work are 400 000 points too many and that is why only required part of data are transferred to control computer. This required part of data you have to set-up separately for every pair of channels A+B, C+D, E+F and G+H before first round by means of your experiences.
	After shooting of first round of series you can find out, that your guess of required data was incorrect, because required signal is not present (signal is out of time window) or amount of data is too big (time for transfer of data from TR 2519 to control computer is very long). Usually you have to delete this round, to correct of time intervals and to shot next "first" round etc. This TR 2519 presents new method for solving of this problem. You have to correct only the time intervals for reading of data and to reread the same data by using of command READ without shooting of new "first" round. It is possible to repeat this action until the settings is acceptable. Then you can continue with shooting of next rounds, but without possibility of other corrections of time intervals.
	Function BREAK serves for necessary manual breaking of measurement and reading of data from TR 2519 for sample rates 50 kHz and less (it substitutes the button STOP).
	After triggering the TR 2519 measures input signals and stores data on internal memory. Because the memory is very deep (300 000 points) and TR 2519 fills always all the memory, by using of sample rate 100 Hz you have to wait 3000s for next measurement! TR 2519 solves this problem by use of function BREAK. After exceeding the longest time interval for reading of data this function could be used for breaking of measurement and for reading of data. This time is also maximum value for correction of time intervals by means of function READ.
	Function BREAK is accessible only for sampling frequency 50 kHz and less, because filling of all RAM by 100 kHz takes only 4s (1 MHz – 0,4 s).
	4.6 Working with Electronic Target WTS03
	4.6.1 Connecting Target to TR 2519


	The program allows connection up to two electronic targets WTS03 to single Transient Recorder TR 2519. Recommended connection to TR 2519:
	4.6.2 How to Measure and Target Data Evaluation

	The knowledge of basic measurements on TR 2519 are supposed and that is why only some specific properties will be explained in details. Everything will be described on the example of EPVAT measurement with single target system.
	At first set required method of data evaluation in Settings > Preferences > Misc (Statistical or Graphical). Setting can be changed also for measured data and than all values are recalculated.
	Run measurement File > New or use the button /, type required name of series and fill out CIP blank form (if you will use graphical method of target evaluation, do not forget enter the bullet diameter). The panel of virtual instrument appears. Set it according to following picture:
	Fig. 51: Virtual panel
	Optical gates of target have response time for about 1­2 µs and sample rate 1 MHz is usually sufficient. Using rate higher than 5 MHz usually does not provide better accuracy of measurement. We strongly do not recommend to use lower value than 1 MHz !!! The other adjustment (input voltage range, trigger level etc.) should be chosen according to concrete conditions (ammunition type, distance and interference). The setting from the picture can be thought as default for most measurement, but serviceman should recommend concrete suitable setting during installation of target at customer.
	If TR 2519 setting is done, the first round of series can be shot. This is example of record from channel G and H:
	Fig. 52: Graph of target system
	Target system converts coordinates by means of oblique gates to time interval. The first pair of overlapping impulses are given by pass of bullet through first normal gate, the last pair of overlapping impulses are given by second normal gate. These gates form the pair at once for measuring of velocity on the base 0.6 m. The middle two impulses are created by pass of bullet through oblique gate X (brown color, G) and Y (green color, H) and their position against the impulses from the normal gates contains information about the position of bullet. The method for evaluation of position X and Y is built on this process. Open the window for computing by means of the button / Computing, which is in the panel of tools in main program window.
	Fig. 53: Data analysis of target system
	The cursors can be adjusted as usually (see previous chapters) by means of buttons / Edit, / Apply to all and / Escape. The difference is in the fact, that there are four vertical cursors instead of two common cursors. Cursor 1 and 2 determinates the interval for impulse searching from the first orthogonal gate , cursor 2 and 3 determinates the interval for impulse searching from the oblique gate X (or Y) and cursor 3 and 4 is for impulse searching from the second orthogonal gate. Set threshold level so as reading of point from the curve has been reliable and interference has been minimal. We recommend to work with falling edge of impulse (the impulse has higher edge slope and reading will be more accurate). Setting of minimum acceptable impulse length you can reach better interference rejection (shock waves etc.).
	The whole building of method is viewed from previous picture for calculation of X axis and from following picture for calculation of Y axis :
	Fig. 54: Building method
	The next rounds are shot with common way (see chapter B 4.5 Shooting of remained rounds of relevant series).
	It is possible to watch also picture of target 1 and 2 in shooting process.
	It can be activated/deactivated by pressing the button / /.
	Fig. 55: Graph of target
	Selected method for target evaluation is pictured in the bracket of upper left bar. Active hit is highlighted by red color and its measured course is also pictured in main program window. It is possible to make switching active hit by means of the selection of pictured round in main program window. You have to click on the relevant hit. The coordinates of active hit are pictured upper right.
	It is possible to switch representation of relevant group by means of the buttons if the round are allocated to the groups by means of the function Group Organizer / after measurement process - see Fig. 56.
	The set of buttons (to the right) serves for switching on/off the relevant calculations, which are pictured on the target and for listing of numeric values. The last button Distance can admeasure distance between active point and next any point.
	The function Zoom can be activated with mouse left click, by cursor moving (drag & drop, it appears zoom rectangle) and button release. The other option is in the picture Fig. 57. The function is activated by clicking on the left or bottom border of target. It is possible to set numerically the scale of axes or choose the function Auto Scale (button Auto).
	Button Coefficients serves for calibration of target system (see WTS03 User's Guide).
	Button Fixed serves for setting of target scale to predefined values (see setting of axes in menu Settings), button Auto sets Auto Scale of X and Y axe.
	It is possible to transfer picture of target through clipboard (by means of /, Edit > Copy or Ctrl+C) to any Windows application - all rounds on the target are enumerated.
	Fig. 56: Selection of group
	Fig. 57: Distance evaluation
	If some rounds cannot be evaluated (for example by reason of signal exceeding from the limitations, which are set in the calculations), their numbers appear in the list below the target. The list of not evaluated rounds can be displayed or hidden by means of the bar /, see Fig. 58. If the round from this list is chosen, relevant course of signal is displayed in main program window and it is possible to make correction of evaluation by means of the button / Computing. The round is then automatically aligned to the target.
	Fig. 58: Distance evaluation
	The result of measurement is picture of target (see above) and report, which is accessible by means of the button /. 
	If the rounds are allocated to the groups, they are also allocated in report. Each part has partial statistic and Overall statistic is released in the end. The meaning of single items (results) will be explained on the following sample of report. The report is not complete, but only the end part (partial statistics are quite analogical).
	Overall statistic
	==================================================================================================
	       | 1 (Target)       | 2 (Velocity UP) | 3 (Velocity ->) | 4 (Velocity <-) | 5 (Velocity DN) 
	 Round |  X [mm]   Y [mm] |  Speed [m/s]    |  Speed [m/s]    |  Speed [m/s]    |  Speed [m/s]    
	--------------------------------------------------------------------------------------------------
	  Avg  |    - 58     - 38 |      685.2      |      684.1      |      687.6      |      685.7      
	  SD   |       4       24 |        3.4      |        3.0      |        3.0      |        3.2      
	  Max  |    - 53      - 8 |      687.9      |      686.6      |      690.0      |      688.3      
	  Min  |    - 63     - 67 |      680.7      |      680.1      |      683.7      |      681.4      
	 Delta |      10       59 |        7.3      |        6.5      |        6.3      |        6.9      
	 Wk[J] |                  | 0.000E+00       | 0.000E+00       | 0.000E+00       | 0.000E+00       
	--------------------------------------------------------------------------------------------------
	 CIP K |       2        2 |        2.0      |        2.0      |        2.0      |        2.0      
	 Avg + |    - 50       10 |      691.9      |      690.1      |      693.6      |      692.2      
	 Avg - |    - 66     - 86 |      678.4      |      678.1      |      681.6      |      679.2      
	Overall target statistic
	========================================================================
	     CIP K =  2            Avg  |  SD   |  Max  |  Min  | Delta | Avg + 
	------------------------------------------------------------------------
	Impact Mean Point Xm   :  - 58  |    4  | - 53  | - 63  |   10  |
	Impact Mean Point Ym   :  - 38  |   24  |  - 8  | - 67  |   59  |
	Radius Rm              :    23  |    7  |   34  |   16  |   17  |   38 mm
	Radius R100            :    55  |   32  |  101  |   28  |   73  |  119 mm
	Radius R50             :    20  |    8  |   31  |   14  |   17  |   35 mm
	Radius Rdisp           :    42  |   20  |   71  |   24  |   47  |   83 mm
	Diameter 2R100         :    84  |   41  |  142  |   48  |   93  |  165 mm
	Group Rect. Width  (W) :    50  |   13  |   63  |   38  |   26  |   75 mm
	Group Rect. Height (H) :    76  |   41  |  134  |   44  |   90  |  159 mm
	Group Rect. Sum W + H  :   126  |   47  |  192  |   44  |  148  |  220 mm
	Largest Distance       :    83  |   41  |  142  |   45  |   96  |  166 mm
	There is Overall statistic , on the top part. It is built from results in Computing window. These variable are in the single columns:
	Avg:  average value of measured variable
	SD :  standard deviation
	Max:  maximal value
	Min:  minimal value
	Delta:  dispersion ( = |Max – Min| )
	Wk [J]:  energy of the round (only for velocity)
	CIP K:  value of C.I.P. coefficient
	Avg +:  corrected value ( [Avg +] = [Avg] + [CIP K] 
	x [SD] )
	Avg –:  corrected value ( [Avg –] = [Avg] – [CIP K] 
	x [SD] )
	There is Overall target statistic on the bottom part. The rows represent final values, statistically processed according to previous paragraph:
	Impact Mean Point Xm:  mean point of hit – X coordinate (for statistical method it is calculated as normal (mean) value of X coordinates, for graphical method then for example for 10 hits it lies in half of distance between 5th. and 6th. hit, resp. for 11 hits it lies in 6th hit, calculated in direction of X axis).
	Impact Mean Point Ym:  mean point of hit – Y coordinate (for statistical method it is calculated as normal (mean) value of Y coordinates, for graphical method then for example for 10 hits it lies in half of distance between 5th. and 6th. hit, resp. for 11 hits it lies in 6th hit, calculated in direction of Y axis).
	Radius Rm: radius of mean circle (i.e. circle with the center (Xm,Ym) and radius which is equal to mean value from distance of each hit from the point (Xm,Ym)). It is not generated for graphical method.
	Radius R100: radius of smallest circle with the center (Xm,Ym), containing all hits.
	Radius R50: radius of circle with the center (Xm,Ym), containing one half of hits (if it is for example 10 shots, the circle has radius of mean value of distance of 5th and 6th hit from center, resp. for 11 hits it passes directly by 6th hit).
	Radius Rdisp: radius of smallest circle, containing all hits.
	Diameter 2R100: diameter of smallest circle, containing all hits.
	Group Rect. Width (W): distance of outer hits in direction of X axis
	Group Rect. Height (H): distance of outer hits in direction of Y axis .
	Group Rect. Sum W + H: sum of previous both results (one half of perimeter of smallest rectangle, which contains all hits and it is oriented in direction of X and Y axis).
	Largest Distance: largest distance between any two hits.
	The difference between statistical method and graphical method.
	Statistical method calculates with the center of hits, while graphical method calculates with internal / external contact of penetrations (when caliber is positive / negative number) - calculated values are corrected by caliber (diameters and distances), resp. one half of caliber (radiuses).

